[CFT] TexLive port

Denny Lin dennylin93 at hs.ntnu.edu.tw
Tue Aug 14 01:49:33 UTC 2012


On Mon, Aug 13, 2012 at 09:50:15AM +0200, Dominic Fandrey wrote:
> On 13/08/2012 04:45, Denny Lin wrote:
> >On Sun, Aug 12, 2012 at 10:12:33AM +0200, Dominic Fandrey wrote:
> >>On 31/07/2012 00:48, Dominic Fandrey wrote:
> >>Here we go:
> >>http://www.home.hs-karlsruhe.de/~fado1011/texlive/
> >>
> >># mkdir ~/texlive
> >># cd ~/texlive
> >># fetch http://www.home.hs-karlsruhe.de/~fado1011/texlive/patch-ports-graphics-poppler.txt http://www.home.hs-karlsruhe.de/~fado1011/texlive/shar-ports-print-texlive.txt
> >># cd /usr
> >># patch < ~/texlive/patch-ports-graphics-poppler.txt
> >># sh ~/texlive/shar-ports-print-texlive.txt
> >># portmaster graphics/poppler
> >
> >Adding this line to print/texlive-base/Makefile should remove the need
> >to patch graphics/poppler:
> >CFLAGS+= -I${LOCALBASE}/include
> >
> >>If you don't have teTeX installed:
> >># portmaster print/texlive
> >>
> >>If you have teTeX installed:
> >># portmaster -o print/texlive-texmf print/teTeX-texmf
> >># portmaster -o print/texlive-base print/teTeX-base
> >># portmaster -o print/texlive print/teTeX
> >
> >This probably needs to be run before portmaster if teTeX is installed:
> ># pkg_delete -f 'dvipsk-tetex-*'
> ># pkg_delete -f 'xdvik-tetex-*'
> >
> >print/texlive-base fails to build/install for some reason:
> >gmake[4]: Leaving directory `/usr/ports/print/texlive-base/work/texlive-20120701-source/texk/texlive'
> >gmake[3]: Leaving directory `/usr/ports/print/texlive-base/work/texlive-20120701-source/texk/texlive'
> >gmake[2]: Leaving directory `/usr/ports/print/texlive-base/work/texlive-20120701-source/texk/texlive'
> >gmake[1]: Leaving directory `/usr/ports/print/texlive-base/work/texlive-20120701-source/texk'
> >texlinks: config file `fmtutil.cnf' not found.
> Something must have gone wrong with texlive-texmf. The file should be
> in ${LOCALBASE}/share/texmf/web2c/fmtutil.cnf
> >I tried searching for fmtutil.cnf:
> ># find work/texlive-20120701-source/ -name fmtutil.cnf
> >work/texlive-20120701-source/texk/tetex/fmtutil.cnf
> >
> >This error occurs even when I patched poppler, so it should be unrelated
> >to the workaround mentioned above.
> Maybe just try to wipe all the teTeX stuff and make a clean start
> with print/texlive. It works in my Tinderbox, so the installation
> procedure should be fine.

Ok, it seems that a few files were accidentally deleted in the process
of replacing teTeX with Tex Live. I reinstalled the Tex Live ports, and
the error disappeared.

However, I noticed a problem with the symlinks in print/texlive-base.
For instance, /usr/local/bin/mktexfmt pointed to fmtutil at first, but
this line in post-install:
changed it to /usr/local/share/texmffmtutil. Not all the symlinks need
to be modified.

I've attached a fix although it's not very elegant (everything worked as
expected after the symlinks were fixed). I also reworked texlive-texmf
to build the plist and install the files at the same time to make it run

Thanks for all the time and effort you put into porting Tex Live! It
would be great to see TeX Live replace teTeX, regardless of whose port
is used.

Denny Lin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: texlive.patch
Type: text/x-diff
Size: 1823 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20120814/9b99edf1/texlive.bin

More information about the freebsd-ports mailing list