[CFT] editors/emacs to 24.1

Kevin Oberman kob6558 at gmail.com
Fri Aug 3 18:42:37 UTC 2012

On Fri, Aug 3, 2012 at 10:19 AM, Marco Beishuizen <mbeis at xs4all.nl> wrote:
> On Fri, 3 Aug 2012, the wise Ashish SHUKLA wrote:
>> I use following, and it seems to work fine for me:
>> --8<---------------cut here---------------start------------->8---
>> #!/bin/sh
>> xrdb ~/.Xdefaults
>> xmodmap ~/.Xmodmap
>> gnome-screensaver &
>> exec dbus-launch --exit-with-session ck-launch-session fluxbox 2>&1
>> >$HOME/.xsession-errors
>> --8<---------------cut here---------------end--------------->8---
>> FTR, my Emacs is compiled with GTK3/DBUS/GCONF options.
>> Could you try it?
> I've tried all this but no differences. Still crashes and lockups.
> Regards,
> Marco
> --
> The distinction between Freedom and Liberty is not accurately known;
> naturalists have been unable to find a living specimen of either.

Upgraded to 24.1 this morning. Still 9.1-PRERELEASE updated on 7/31
w/amd64 system.

So far I have no real problems with 24.1, but I built without DBUS.
and I am still getting failures when I fire up emacs when sudo'ed to
(emacs:1998): GLib-GIO-CRITICAL **: g_dbus_connection_add_filter:
assertion `G_IS_DBUS_CONNECTION (connection)' failed
g_dbus_connection_real_closed: Remote peer vanished with error:
Underlying GIOStream returned 0 bytes on an async read
(g-io-error-quark, 0). Exiting.
Exit 15

If I remove the DBUS_SESSION_BUS_ADDRESS env. variable, emacs starts
and runs fine, but I still get:
(emacs:2002): GLib-GIO-CRITICAL **: g_dbus_connection_add_filter:
assertion `G_IS_DBUS_CONNECTION (connection)' failed

I had hoped that removal of the DBUS option would eliminate this, but
no joy. I am using GTK2 and have the following options:
     CANNA=off: Canna support
     DBUS=off: D-Bus support
     GCONF=on: gconf backend
     GIF=on: GIF support
     GNUTLS=on: SSL/TLS support via GnuTLS
     GSETTINGS=on: GSettings support
     JPEG=on: JPEG support
     M17N=on: M17N support for text-shaping
     MAGICK=on: ImageMagick Library
     OTF=on: Opentype fonts suport
     PNG=on: PNG support
     SCROLLBARS=on: Toolkit scroll-bars
     SOUND=on: Sound support
     SOURCES=on: Install sources
     SVG=on: SVG image support
     SYNC_INPUT=on: Synchronously process asynchronous input
     TIFF=on: TIFF support
     XFT=on: Xft support
     XIM=on: X Input Method Support
     XML=on: XML Parser support
     XPM=on: XPM pixmaps support

While the effects of some options seems obvious, others are unclear.
I'd love to know what they all mean, especially things like GCONF,
DBUS, and GSETTINGS. Perhaps some other setting overrides the DBUS

NOTE: This problem is only an annoyance and it is NOT new to 24.1, so
I am partly hijacking the thread.
R. Kevin Oberman, Network Engineer
E-mail: kob6558 at gmail.com

More information about the freebsd-ports mailing list