CFT: vlc 2.0.3 - want to know where it works and where only partly

Juergen Lock nox at
Thu Aug 2 19:25:52 UTC 2012

In article <20120801213128.7956cef34d5f5a5419f78de2 at> you write:
>On Wed, 01 Aug 2012 20:34:44 +0200
>Oliver Heesakkers <freebsd at> wrote:
>> [...]
>> At the start of configure it is reported that --with-live555-tree is an 
>> unrecognized option.
>> Changing line 381 of the patched Makefile for vlc to:
>> CPPFLAGS+=-I${LOCALBASE}/live/liveMedia/include
>> and removing the backslash from the line before of course, looks like a good 
>> solution to me.
Yeah I fixed it now as posted.  (also needed additional LDFLAGS.)
Here is the link again:

>So a bit more of reports :
>FreeBSD 9.0-RELEASE-p3
>CC=clang CXX=clang++ CPP=clang-cpp (base system version)
>All ports up to date from a portsnap run, built with WITH_NEW_XORG and using the x11/nvidia-driver x11 driver (GeForce 8800GT).
>need the fix above to build with livemedia support
>fails to load qt interface :
>% vlc
>VLC media player 2.0.3 Twoflower (revision 2.0.2-93-g77aa89e)
>[0x802055198] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
>[0x8021909d8] main interface error: corrupt module: /usr/local/lib/vlc/plugins/gui/
>Remote control interface initialized. Type `help' for help.
>The strange thing is it worked with the vlc-2.0.3-001.patch version. cvlc is running fine. Building with base gcc/g++ is also fine.

 Hm I just built the latest patch version with base clang on 9.1 beta
and still don't see this problem.  Could this be some temporary fault
i.e. have you tried rebuilding it a second time?

 Thanx, :)

More information about the freebsd-ports mailing list