New perl, why not: perl-after-upgrade

Heino Tiedemann rotkaps_spam_trap at gmx.de
Thu May 19 08:35:06 UTC 2011


Hi,

Is there e reason why in ports/UPDATING is this mentioned:

,----[ 20110517 ]
| 0) Fix pkgdb.db (for safety): pkgdb -Ff
| 1) Reinstall new version of Perl (5.14): env DISABLE_CONFLICTS=1 portupgrade ...
| 2) Reinstall everything that depends on Perl: ...
`----


and not this:

,----[ man perl-after-upgrade ]
| The standard procedure after a perl port (lang/perl5.X) upgrade is to
| basically reinstall all other packages that depend on perl.  This is
| always a painful exercise.  The perl-after-upgrade utility makes this
| process mostly unnecessary.
`----


Heino



More information about the freebsd-ports mailing list