OO 3.3.0 fails to build "moz" module on amd64 8-STABLE

Lawrence Stewart lstewart at freebsd.org
Sun May 8 04:11:39 UTC 2011


Hi,

I've attempted to build OO 3.3.0 on two separate machines set up from 
scratch recently and both are unable to complete the OO build.

My most recent attempt to build is with a ports tree cvsup'd yesterday 
(2011-05-07) and all my installed ports were built from the ports tree 
and are up to date. Some details about the system:

lstewart at lstewart-laptop> uname -a
FreeBSD lstewart-laptop 8.2-STABLE FreeBSD 8.2-STABLE #0 r221492: Fri 
May  6 00:41:20 EST 2011 
lstewart at lstewart-laptop:/usr/obj/usr/src/sys/GENERIC  amd64

Relevant lines from /etc/make.conf:

.if ${.CURDIR:M*/editors/openoffice.org-3}
WITH_KDE4=1
LOCALIZED_LANG=en-GB
.endif

I'm running KDE 4.6.2.




The problem stems from the "moz" build module. Here are the last few 
lines of console output when the make dies:

##########
Entering 
/usr/ports/editors/openoffice.org-3/work/OOO330_m20/drawinglayer/util

drawinglayer deliver

Entering /usr/ports/editors/openoffice.org-3/work/OOO330_m20/slideshow/util

slideshow deliver

1 module(s):
         moz
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making 
/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz

Attention: if you fix the errors in above module(s) you may prolongue 
your the build issuing command:

         build --from moz

*** Error code 1

Stop in /usr/ports/editors/openoffice.org-3.
##########




The OO build log for the "moz" module says this:

##########
gmake[5]: Entering directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir/mailnews/extensions/smime/build'
Makefile:83: *** missing separator.  Stop.
gmake[5]: Leaving directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir/mailnews/extensions/smime/build'
gmake[4]: *** [export] Error 2
gmake[4]: Leaving directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir/mailnews/extensions/smime'
gmake[3]: *** [export] Error 2
gmake[3]: Leaving directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir/mailnews/extensions'
gmake[2]: *** [export] Error 2
gmake[2]: Leaving directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir/mailnews'
gmake[1]: *** [tier_99] Error 2
gmake[1]: Leaving directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir'
gmake: *** [default] Error 2
dmake:  Error code 2, while making 
'./unxfbsdx.pro/misc/build/so_built_ooo_mozab'
##########




Sure enough, line 83 of 
/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir/mailnews/extensions/smime/build/Makefile 
looks like this:

SHARED_LIBRARY_LIBS + = $(DIST)/lib/$(LIB_PREFIX)msgbsutl_s.$(LIB_SUFFIX)

The space between the "+" and "=" looks like the problem to me. Some 
sort of Makefile template problem perhaps?

If I delete the space to make "+=" and re-run make from the 
editors/openoffice.org-3 port dir, the build dies again in the "moz" 
module. The console output when the make dies this time looks like:

##########
Entering 
/usr/ports/editors/openoffice.org-3/work/OOO330_m20/drawinglayer/source/animation

slideshow deliver

Entering 
/usr/ports/editors/openoffice.org-3/work/OOO330_m20/drawinglayer/util

drawinglayer deliver

1 module(s):
         moz
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making 
/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz

Attention: if you fix the errors in above module(s) you may prolongue 
your the build issuing command:

         build --from moz

*** Error code 1

Stop in /usr/ports/editors/openoffice.org-3.
##########





and the last few lines of the OO build log output for the "moz" module 
says this:


##########
gmake[5]: Entering directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir/mailnews/extensions/smime/build'
nsMsgSMIMEFactory.cpp
c++ -o nsMsgSMIMEFactory.o -c -I../../../../dist/include/system_wrappers 
-include ../../../../../config/gcc_hidden.h -DMOZILLA_INTERNAL_API 
-DOSTYPE=\"FreeBSD8\" -DOSARCH=\"FreeBSD\" -DBUILD_ID=0000000000 
-I../../../../dist/include/xpcom -I../../../../dist/include/string 
-I../../../../dist/include/mime -I../../../../dist/include/msgcompose 
-I../../../../dist/include/pipnss -I../../../../dist/include/necko 
-I../../../../dist/include/intl -I../../../../dist/include/caps 
-I../../../../dist/include/msgsmime -I../../../../dist/include 
-I../../../../dist/include/nspr    -I/usr/local/include   -fPIC 
-I/usr/local/include  -I/usr/local/include -fno-rtti -fno-exceptions 
-Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual 
-Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long 
-pedantic -fshort-wchar -pipe  -DNDEBUG -DTRIMMED -O 
-I/usr/local/include  -I/usr/local/include -DMOZILLA_CLIENT -include 
../../../../mozilla-config.h -Wp,-MD,.deps/nsMsgSMIMEFactory.pp 
../../../../../mailnews/extensions/smime/build/nsMsgSMIMEFactory.cpp
gmake[5]: *** No rule to make target 
`../../../../dist/lib/libmsgbsutl_s.a', needed by `libmsgsmime.so'.  Stop.
gmake[5]: Leaving directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir/mailnews/extensions/smime/build'
gmake[4]: *** [libs] Error 2
gmake[4]: Leaving directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir/mailnews/extensions/smime'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir/mailnews/extensions'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir/mailnews'
gmake[1]: *** [tier_99] Error 2
gmake[1]: Leaving directory 
`/usr/ports/editors/openoffice.org-3/work/OOO330_m20/moz/unxfbsdx.pro/misc/build/mozilla/X_objdir'
gmake: *** [default] Error 2
dmake:  Error code 2, while making 
'./unxfbsdx.pro/misc/build/so_built_ooo_mozab'
##########

and that's where I run out of clue about how to fix the problem ;)

Any help to fix this would be greatly appreciated.

Cheers,
Lawrence


More information about the freebsd-ports mailing list