Ivan Dolezal Ivan.Dolezal at
Thu Feb 17 14:33:23 UTC 2011


   I am trying to portsnap/portupgrade/portmaster this application for
last week ...and when I run it, I always end up with 

# /usr/local/etc/rc.d/openvasd onestart
Starting openvasd.
[4038]() gpgme_new failed: User defined source 1/Not operational
Segmentation fault (core dumped)

Google gave me back many questions and no answer for this

 pkg_info | grep openvas
openvas-client-2.0.4_2 A GUI client for OpenVAS
openvas-libnasl-2.0.1_2 NASL libraries for OpenVAS
openvas-libraries-2.0.3 Libraries for OpenVAS
openvas-plugins-1.0.7_2 Plugins for OpenVAS
openvas-server-2.0.2_2 A security scanner: a fork of Nessus

 pkg_info | grep gpgme
gpgme-1.3.0_3       A library to make access to GnuPG easier
libassuan-2.0.1_1   IPC library used by GnuPG and gpgme

I am running FreeBSD 8.1-RELEASE-p2

gdb openvasd
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and
you are
welcome to change it and/or distribute copies of it under certain
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
This GDB was configured as "i386-marcel-freebsd"...(no debugging
symbols found)...
(gdb) run
Starting program: /usr/local/sbin/openvasd
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbLoading the plugins... 2193 (out of 20405)[4076]()
gpgme_new failed: User defined source 1/Not operational

Program received signal SIGSEGV, Segmentation fault.
0x28106277 in _gpgme_release_result () from

I found

tried no_signature_check=yes , didn't help

Thank you VERY MUCH!

More information about the freebsd-ports mailing list