Chris Whitehouse cwhiteh at onetel.com
Wed Aug 31 22:30:10 UTC 2011

On 31/08/2011 20:00, Ruslan Mahmatkhanov wrote:
> Chris Whitehouse wrote on 31.08.2011 22:34:
>> On 31/08/2011 14:13, Ruslan Mahmatkhanov wrote:
>>> perryh at pluto.rain.com wrote on 31.08.2011 09:29:
>>>> Forwarding to ports@, which seems more likely to yield an answer to
>>>> this particular inquiry than questions@
>>>> Please keep the OP, who is probably not subscribed to ports@, in the
>>>> Cc: list.
>>>> ====================================================================
>>>> Are there any plans to bump it to Python and a recent release?
>>>> I emailed the maintainer a while back but got no response.
>>>> thanks
>>>> Chris
>>> Here is:
>>> a) diff to a previous port:
>>> http://happy-nation DOT by DOT ru/ports/zim-0.52.diff.txt
>>> b) updated port tarball:
>>> http://happy-nation DOT by DOT ru/ports/zim-0.52.tgz.txt
>>> (Just rename it to zim-0.52.tgz and unpack instead of current zim port
>>> directory).
>>> It works fine to me. Please test and report back is all is alright. If
>>> it does, i'll sent problem report to update it in teh tree.
>> Hi Ruslan,
>> first thanks for an amazing quick response and to Perry for forwarding
>> to the right place.
>> On a tinderbox with src from a snapshot of 9.0-CURRENT and recent ports
>> it builds fine, also on the host which has the same src and ports tree
>> it builds and installs fine - but nothing happens when I run the command
>> at least as non-root user. The prompt returns after a moment and that's
>> it. There is no zim process running and ~/.zim is not created.
> About ~/.zim. It now holds it's settings in ~/.config/zim and the actual
> data in ~/Notes (the name of notebook) by default. You also can run zim
> from gnome menu.

Yes they are there now.
>> Running as root there are some error messages which I can report if
>> required which seem to relate to sqlite3. And there is a zim process but
>> still no ~/.zim.
>> Python on this machine is 2.7.2
> And you are right - it uses databases/py-sqlite3 to hold the data, but i
> already have it installed so i overlooked it. Please try to install
> databases/py-sqlite3 first and report back if it helped. It obviously a
> missing dependency and i'll add it before submitting pr. Thanks for
> pointing this out.

Built it in my tinderbox and added it as a package on the 9.0-CURRENT 
box and now zim works there. I haven't done any testing on this box 
beyond starting it as non-root and letting it make a default notebook.

>> However the computer I really want to run it on is running 8.1-RELEASE
>> and ports from around Sept 2010. Python is version 2.6.6. That's my
>> laptop and main day-to-day machine. I'm having problems with the more
>> recent ports on the other machine in relation to nvidia driver and/or
>> flash and/or firefox and would prefer not to upgrade the laptop until
>> those are working.
> Ok, i understand. I'm using intel so can't actually help with this one.
> But i just saw that nvidia-drivers in ports tree were updated to latest
> versions today.

Might be time to have another go thanks.
>> Here's what I did for the laptop.
>> muji2# cd /usr/ports/editors/
>> muji2# mv zim zim-0.29
>> muji2# fetch http://happy-nation DOT by DOT ru/ports/zim-0.52.tgz.txt
>> # munged by me as blocked by my ISP :(
>> zim-0.52.tgz.txt 100% of 3476 B 11 MBps
>> muji2# mv zim-0.52.tgz.txt zim-0.52.tgz
>> muji2# tar xvf zim-0.52.tgz
>> x zim/
>> x zim/Makefile
>> x zim/distinfo
>> x zim/pkg-descr
>> x zim/pkg-plist
>> muji2# cd zim
>> muji2# ls
>> Makefile distinfo pkg-descr pkg-plist
>> muji2# pwd
>> /usr/ports/editors/zim
>> muji2# make
>> ===> zim-0.52 cannot install: Unknown component pygobject.
>> *** Error code 1
> You may just remove pygobject from USE_GNOME in Makefile since you
> already have py26-gobject-2.21.1 installed, or you may add this to
> RUN_DEPENDS instead (but still removing pygobject from USE_GNOME):
> pygobject-codegen-2.0:${PORTSDIR}/devel/py-gobject

I added to RUN-DEPENDS. Next problem was:

muji2# make fetch
===>  Vulnerability check disabled, database not found
===>  License accepted by the user
=> zim-0.52.tar.gz is not in /usr/ports/editors/zim/distinfo.
=> Either /usr/ports/editors/zim/distinfo is out of date, or
=> zim-0.52.tar.gz is spelled incorrectly.
*** Error code 1

Stop in /usr/ports/editors/zim.

I fixed this just by putting the md5 in distinfo, the other lines were 
correct. distinfo is now

MD5 (zim-0.52.tar.gz) = fddba2cab1eb4762aa5125a3f4e15fe8
SHA256 (zim-0.52.tar.gz) = 
SIZE (zim-0.52.tar.gz) = 1195768

Now it builds and installs and is working fine, _and_ my original 
problem has gone away.

thanks very much for your help. I'll drop the author a line to say it's 
been fixed.


More information about the freebsd-ports mailing list