Chris Whitehouse cwhiteh at onetel.com
Wed Aug 31 18:50:57 UTC 2011

On 31/08/2011 14:13, Ruslan Mahmatkhanov wrote:
> perryh at pluto.rain.com wrote on 31.08.2011 09:29:
>> Forwarding to ports@, which seems more likely to yield an answer to
>> this particular inquiry than questions@
>> Please keep the OP, who is probably not subscribed to ports@, in the
>> Cc: list.
>> ====================================================================
>> Date: Tue, 30 Aug 2011 13:52:12 +0100
>> From: Chris Whitehouse<cwhiteh at onetel.com>
>> To: User Questions<freebsd-questions at freebsd.org>
>> Subject: editors/zim
>> Hi,
>> I have a problem with Zim which I wrote to the author about he
>> replied and said;
>> "I'm afraid version 0.29 is no longer supported. This was the last
>> version in the Perl branch, since we moved to Python there have been
>> already 10 more releases. So please try the latest version (0.52)."
>> Are there any plans to bump it to Python and a recent release?
>> I emailed the maintainer a while back but got no response.
>> thanks
>> Chris
> Here is:
> a) diff to a previous port:
> http://happy-nation DOT by DOT ru/ports/zim-0.52.diff.txt
> b) updated port tarball:
> http://happy-nation DOT by DOT ru/ports/zim-0.52.tgz.txt
> (Just rename it to zim-0.52.tgz and unpack instead of current zim port
> directory).
> It works fine to me. Please test and report back is all is alright. If
> it does, i'll sent problem report to update it in teh tree.

Hi Ruslan,

first thanks for an amazing quick response and to Perry for forwarding 
to the right place.

On a tinderbox with src from a snapshot of 9.0-CURRENT and recent ports 
it builds fine, also on the host which has the same src and ports tree 
it builds and installs fine - but nothing happens when I run the command 
at least as non-root user. The prompt returns after a moment and that's 
it. There is no zim process running and ~/.zim is not created.
Running as root there are some error messages which I can report if 
required which seem to relate to sqlite3. And there is a zim process but 
still no ~/.zim.
Python on this machine is 2.7.2

However the computer I really want to run it on is running 8.1-RELEASE 
and ports from around Sept 2010. Python is version 2.6.6. That's my 
laptop and main day-to-day machine. I'm having problems with the more 
recent ports on the other machine in relation to nvidia driver and/or 
flash and/or firefox and would prefer not to upgrade the laptop until 
those are working.

Here's what I did for the laptop.

muji2# cd /usr/ports/editors/
muji2# mv zim zim-0.29
muji2# fetch http://happy-nation DOT by DOT ru/ports/zim-0.52.tgz.txt
# munged by me as blocked by my ISP :(
zim-0.52.tgz.txt                              100% of 3476  B   11 MBps
muji2# mv zim-0.52.tgz.txt zim-0.52.tgz
muji2# tar xvf zim-0.52.tgz
x zim/
x zim/Makefile
x zim/distinfo
x zim/pkg-descr
x zim/pkg-plist
muji2# cd zim
muji2# ls
Makefile        distinfo        pkg-descr       pkg-plist
muji2# pwd
muji2# make
===>  zim-0.52 cannot install: Unknown component pygobject.
*** Error code 1

Stop in /usr/ports/editors/zim.

muji2# pkg_info -Ix py
py26-cairo-1.8.8_1  Python bindings for Cairo
py26-coverage-3.4   Code coverage measurement for Python
py26-gobject-2.21.1 Python bindings for GObject
py26-gtk-2.17.0_4   A set of Python bindings for GTK+
py26-setuptools-0.6c11 Download, build, install, upgrade, and uninstall 
Python pac
py26-tkinter-2.6.6_3 Python bindings to the Tk widget set
py26-xdg-0.19       A python library to access freedesktop.org standards
pysol-4.82_1        Solitaire game, written in Python
pysol-sound-server-3.01_4 Python extension module to play sounds and 
background music
python26-2.6.6      An interpreted object-oriented programming language
xdpyinfo-1.1.0      Display information utility for X



More information about the freebsd-ports mailing list