libproxy and libnotify the story continues :D

Johan Hendriks Johan at
Wed Aug 31 09:13:32 UTC 2011

Hello all, i also ran into the libproxy upgrade problems.

So i tried al the stuff i found on the mailling list so far.

I tried the solution from

find /usr/local/lib -name "*.la" | \
	xargs grep -l /usr/local/lib/ | \
	xargs -L 1 pkg_info -W | \
	awk '{ print $6 }' | \
	sort | \
	uniq | \
	xargs portupgrade -f

But this ends like the following.

/usr/include/machine/endian.h:130: syntax error, unexpected ';' in ' return (__extension__ ({ register __uint32_t __X = (_x); __asm ("bswap %0" : "+r" (__X)); __X; }));' at ';'
/libexec/ Shared object "" not found, required by ""
Command '['/usr/ports/graphics/libchamplain/work/libchamplain-0.8.1/champlain-gtk/tmp-introspectpyOYLR/GtkChamplain-0.8', '--introspect-dump=/usr/ports/graphics/libchamplain/work/libchamplain-0.8.1/champlain-gtk/tmp-introspectpyOYLR/types.txt,/usr/ports/graphics/libchamplain/work/libchamplain-0.8.1/champlain-gtk/tmp-introspectpyOYLR/dump.xml']' returned non-zero exit status 1
gmake[3]: *** [GtkChamplain-0.8.gir] Error 1
gmake[3]: Leaving directory `/usr/ports/graphics/libchamplain/work/libchamplain-0.8.1/champlain-gtk'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/ports/graphics/libchamplain/work/libchamplain-0.8.1/champlain-gtk'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/graphics/libchamplain/work/libchamplain-0.8.1'
gmake: *** [all] Error 2
*** Error code 1

Stop in /usr/ports/graphics/libchamplain.

I reinstalled libproxy, i reinstalled libgweather and so on, also the poor mans portmaster solution from doug.

But i can not get past this.

Also did a recompile off all the evolution stuff,
Then tried portmaster lib*  in the hope there was a library not installed ok, but that ends with the same error as above.

I am struggling for a day or 4 now with this.

Could someone please help me :D 


More information about the freebsd-ports mailing list