Ruby 19 install(?) failure

Steve Wills swills at
Wed Aug 24 00:33:55 UTC 2011


On 08/23/11 18:08, Kevin Oberman wrote:
> On Tue, Aug 23, 2011 at 2:15 PM, Kevin Oberman <kob6558 at> wrote:
>> I just tried upgrading ruby to lang/ruby19 as per ports/UPDATING.
>> Looks like build just patches and the 'make install' does most of the
>> real work. In any case, it fails.
>> cc -shared -o ../../.ext/amd64-freebsd8/ zlib.o -L. -L../.. -L.
>>  -rdynamic -Wl,-soname,../../.ext/amd64-freebsd8/  -Wl,-R
>> -Wl,/usr/local/lib -L/usr/local/lib -lruby19 -lz  -lthr -lrt -lcrypt
>> -lm -L/usr/local/lib  -rpath=/usr/lib:/usr/local/lib -pthread  -lc
>> making ruby19
>> make: don't know how to make NO_DEPENDS. Stop
>> *** Error code 2
>> Running 8.2-Stable of Aug 19.
>> Any idea what's wrong?
>> Thanks!
> Now I'm very confused. After the same failure three times, I tied a
> manual "make install"
> and it worked. I then re-ran the "portmaster -o lang/ruby19
> /lang/ruby18 and it semed to be OK, but when I ran the "portmaster -R
> -r lang/ruby-1.9, it tried to install ruby18-gems and that tried to
> re-install ruby18.
> Am I missing something?

My apologies for the trouble. Can you tell me what version of FreeBSD
you're on and what other packages you have installed?


More information about the freebsd-ports mailing list