Ubuntu One port

Koop Mast kwm at rainbow-runner.nl
Thu Aug 11 21:09:44 UTC 2011


On Fri, 2011-08-12 at 00:02 +0300, Anton wrote:
> On 11.08.2011 01:53, Jesse Smith wrote:
> > Hi all,
> >
> > I've been working on a port of the Ubuntu One client. Ubuntu One is a
> > cloud storage service and the client is used to sync files with the
> > remote server.
> >
> > The port has been progressing well and I've reached a point where it
> > builds and installs cleanly on my machine. However, running the software
> > still seems a bit flaky, I don't think the daemon is running properly.
> >
> > Is anyone here willing to give the attached port a try and send me
> > feedback/suggestions?
> 
> Build port is failed for me.
> 
> text of error here:
> 
> ===>   Running ldconfig
> /sbin/ldconfig -m /usr/local/lib
> ===>   Registering installation for evolution-data-server-2.32.1_1
> ===> SECURITY REPORT:
>        This port has installed the following binaries which execute with
>        increased privileges.
> /usr/local/libexec/camel-lock-helper-1.2
> 
>        If there are vulnerabilities in these programs there may be a 
> security
>        risk to the system. FreeBSD makes no guarantee about the security of
>        ports included in the Ports Collection. Please type 'make deinstall'
>        to deinstall the port if this is a concern.
> ===>   Returning to build of ubuntuone-client-1.7.0
> Error: shared library "ebook-1.2.9" does not exist
> *** Error code 1
> 
> Stop in /usr/ports/net/ubuntuone.

There isn't a libebook-1.2.9 in our evolution-data-server port only
libebook-1.2.10. And why not use the USE_GNOME=evolutiondataserver
switch to depend on it? More values are mentioned at line 81 of
Mk/bsd.gnome.mk.

> 
> Is camel-lock-helper-1.2 vulnerable?
> 
I have idea what you mean with this.

-Koop



More information about the freebsd-ports mailing list