Google-earth: memory fault

Paul Schenkeveld fb-ports at
Tue Apr 19 18:01:06 UTC 2011

On Wed, Apr 06, 2011 at 08:24:29PM +0200, Juergen Lock wrote:
> In article <20110405232519.GA60680 at> you write:
> >Hi,
> Hi!
> >
> >Until a couple of months ago, I was happily using google-earth on all
> >my desktops and laptops.  Now, it exits with Memory Fault after
> >creating the startup window, the main window and a tiny pop-up window.
> >The pop-up window does not have a title not contents so I don't know
> >what it's trying to tell me.  After this message, I'm back at the
> >shell prompt, the three google-earth windows stay on the screen and
> >do not react to resize or cancel messages from the window manager.
> >There are 30 ./googleearth-bin processes still running and if I
> >killall -1 googleearth-bin the window these processes and the windows
> >on my screen disappear.
> >
> >One laptop had google-earth running fo nearly two years but one day,
> >probably after the upgrade to google-earth-,1, it started
> >exiting with the above message.  The notebook is running FreeBSD
> >8.2-STABLE #4: Sun Feb 27 12:28:14 CET 2011 i386, has an Intel T7500
> >Core 2 duo CPU and 3 GB RAM.
> >
> >The other laptop runs FreeBSD 8.2-RELEASE #0: Fri Mar 11 21:52:10 CET
> >2011 amd64 on an Intel Q9100 CPU with 4 GB RAM.
> >
> >I can't get googleearth-bin to dump core, it just prints "Memory Fault"
> >and exits.
> >
> >Any ideas ow to debug this?
> Hm googleearth still runs here...  Did you have accellerated gl when
> it still worked?  If not maybe that is broken again...  If you have

Google-earth was fast, I don't know another way to tell whether
accellerated gl worked or not.

> accellerated gl working for native executables but not for linux ones
> you could try enabling AIGLX in your xserver and tell googleearth
> to use that by setting LIBGL_ALWAYS_INDIRECT=1 in it's environment.
>  And if you don't have accellerated gl working at all but are using
> an ati HD3xxx or HD4xxx card you could try setting WITHOUT_NOUVEAU
> in make.conf and rebuilding a few ports after that, see the 20100207
> entry in /usr/ports/UPDATING .

Both laptops have an Nvidia card: Quadro FX 360M on the old i386
laptop and Quadro FX 2700M on the new amd64 laptop.  Both are using
nvidia-driver-256.53_1 and I have re-installed this video driver after
installation/upgrade of linux-dri because of the libGL conflict (and
rebooted the laptop to make sure that the correct kernel module is

On both laptops, I get the main google-earth window, the Start Up Tip
window and then I get "Memory fault", the wrapper script stops and 20
googleearth-bin are still running.

Running google-earth on laptop #1 with $DISPLAY set to laptop #2 works
and also vice versa, of couse it's quite slow this way.

>  HTH,
> 	Juergen

Thank you for your help.

Paul Schenkeveld

More information about the freebsd-ports mailing list