problem with php5-extensions installing under freebsd-8.1

John lists at reiteration.net
Fri Sep 24 13:15:46 UTC 2010


Forwarding to this list as php5-extensions appears mysteriously broken -
it doesn't install as anticipated. If this needs to go elsewhere, please
advise me directly, thanks.


-------- Original Message --------
Subject: Re: Trouble enabling GD in php/apache
Date: Fri, 24 Sep 2010 13:42:41 +0100
From: John <lists at reiteration.net>
To: freebsd-questions at freebsd.org

On 24/09/2010 12:52, Andy Wodfer wrote:
> I'm running FreeBSD 8.0 RELEASE.
> 
> I can't get GD enabled. I have installed latestes php5 from ports aswell as
> php5-extensions and enabled GD on the option screen:
> 
> cd /usr/ports/lang/php5
> make deinstall
> make clean
> make rmconfig
> make install clean
> 
> cd /usr/ports/lang/php5-extensions
> make deinstall
> make clean
> make rmconfig
> make install clean
> 
> I'm running the latest Apache 2.2.x version and GD 2.0.35.
> 
> I'm currently doing a portupgrade -a to see if that helps, but I think not.
> 
> What's the correct way of getting GD to work on Ie. a webshop (opencart)?

It seems that php5-extensions isn't installing properly.

I had to install a new server and was surprised the extensions never
loaded. However I knew from other installations that for example the gd
extension should be in extensions.ini - I looked in there and it was
absent. So what I had to do is to search for it. Before I did that, I
had to run locate.updatedb as root. This showed gd.so to be in
/usr/local/ports/graphics/php5-gd/work/php-5.3.3/ext/gd/modules/gd.so

I copied that into /usr/local/lib/php/20090626/ and edited
/usr/local/etc/php/extensions.ini with a line of extension=gd.so

I had to do this with everything selected in php5-extensions, and then
restart the webserver.

FreeBSD 8.1-RELEASE #1: Wed Sep  8 10:21:27 BST 2010 and last csup for
ports was on the 23rd from cvsup.uk.freebsd.org
-- 
John


More information about the freebsd-ports mailing list