x11/sessreg fails to build

David DEMELIER demelier.david at gmail.com
Thu Sep 23 06:28:22 UTC 2010

2010/9/22 David Wolfskill <david at catwhisker.org>:
> On Wed, Sep 22, 2010 at 08:52:02PM +0200, David DEMELIER wrote:
>> ....
>> > There is no utmpx.h on 8.1-RELEASE.
>> >
>> Then it's there because I downgraded from -STABLE, then I should
>> remove it safely ?
> When I do a source upgrade (which I do way more frequently than is
> sane), I augment the instructions in /usr/src/UPDATING so that just
> after "make installkernel", I run "mergemaster -p" (as specified),
> then move /usr/include aside prior to "make installworld": the "make
> installworld" will re-populate /usr/include afresh, and that way I
> know it doesn't contain anything it's not supposed to.
> Peace,
> david
> --
> David H. Wolfskill                              david at catwhisker.org
> Depriving a girl or boy of an opportunity for education is evil.
> See http://www.catwhisker.org/~david/publickey.gpg for my public key.

I finally just rm /usr/include/utmpx.h and it worked. Sorry for my
mistakes. I won't downgrade a system again without cleaning


Demelier David

More information about the freebsd-ports mailing list