current ports Mk make fetch calls wget fails to support schemes

Shaun Amott shaun at
Fri Sep 3 21:20:20 UTC 2010

On Tue, Aug 31, 2010 at 07:39:32PM +0200, Julian H. Stacey wrote:
> make fetch used to call src/ BSD licensed fetch
> it now calls FSF GNU licensed wget,
> You can see why it fails with 
> 	cd sysutils/tarsnap ; make fetch-list
> Even after one has found where 
> 	Unsupported scheme
> comes from & tried to work round it with make.conf assertion of
> 	FETCH_BINARY=/usr/bin/fetch
> as shown in
> /usr/src/usr.bin/fetch is still not used.
> 	Revert Mk invocation back to longer invoke FSF/GNU licensed
> 	wget & instead again invoke BSD licensed src/ provided fetch,
> 	until such time as wget might be capable of offering all
> 	schemes BSD fetch already does.

fetch is still used by ports, it's just that the tarsnap port overrides
it and uses wget. The Makefile says "Workaround for bug in libfetch(3)";
perhaps it has something to do with the self-signed certificate employed
on the master site.

Try FETCH_CMD if you want to force the use of fetch.

Shaun Amott // PGP: 0x6B387A9A
"A foolish consistency is the hobgoblin
of little minds." - Ralph Waldo Emerson
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
Url :

More information about the freebsd-ports mailing list