VirtualBox and nullfs

Cy Schubert Cy.Schubert at
Fri Oct 22 19:57:22 UTC 2010

This is a heads-up for those who might configure their systems in this way.

First some background. I normally build ports in a jail, then copy them 
($LOCALBASE, package databases, etc) to the various systems in my 
infrastructure -- it's all scripted (differences in config files are 
maintained through symlinks). So far so good. The previous time I performed 
a port upgrade I placed /usr/local and friends onto ZFS. This time in a 
subdirectory of /usr, using nullfs (and in some cases NFS) to make the 
final mounts. An example would be /usr/local would be a nullfs mount from 
/usr/pkg/local and /var/db/pkg would be mounted from /usr/pkg/var/db/pkg. 
So far so good, everything worked, until...

The problem began when I tried to run VirtualBox. It came back with a 
sysctl failure. Executing it from it's actual location resolved that issue 
but I still could not run any VMs. Ultimately I removed the nullfs mounts 
and moved /usr/pkg/local back to /usr/local and VirtualBox worked again. If 
/usr/local is mounted from a ZFS filesystem, it works. (Not sure about NFS 
but I suspect it might work too,) However if /usr/local is mounted using a 
nullfs mount VirtualBox fails to run properly. I don't know why yet.

Hopefully if anyone has the same configuration this email should be of 

Cy Schubert <Cy.Schubert at>
FreeBSD UNIX:  <cy at>   Web:


More information about the freebsd-ports mailing list