squidguard + ldap ?

Guido Falsi mad at madpilot.net
Wed Oct 13 14:40:15 UTC 2010

On Wed, Oct 13, 2010 at 02:28:39PM +0200, cyx wrote:
> Hi 
> I am trying to install squidguard with ldap support.
> Every time I compile it, it says:
>  checking for ldap_init in -lldap... no
> configure: WARNING: Cannot find LDAP libraries. LDAP support disabled
> I have openldap (client) installed, and squid works fine with ldap - so
> whats the problem here?

Hi, I'm the maintainer of the squidguard port.

I have tried to reproduce this problem in the past, but never ben able

On a previous instance of this problem from the logs the user sent me I
noticed a missing file in the ldap installation. I asked him to
reinstall(using portmaster for example) the openldap port and try again.
Unluckily he did never report back, so I don't know if it solved the

Could you try this?

Also do check that the file ${LOCALBASE}/lib/libldap.so does exist, is a
softlink and points to an existing openldap so library file.

To analyse your problem furher I will need a full transcript of the failed
build, the config.log file from the failed port and possibly know which
openldap port you have installed.

Thank you in advance!

Guido Falsi <mad at madpilot.net>

More information about the freebsd-ports mailing list