[PATCH] Proposal for a new option framework

Chip Camden sterling at camdensoftware.com
Thu Nov 18 16:14:49 UTC 2010

Quoth Eitan Adler on Wednesday, 17 November 2010:
> > I downloaded it and tried it out.  Whenever I try to navigate around the
> > options, I get a "File specified does not exist" error.  I looked at the
> > source, and it appears to be looking for a license (or "licence" (sic))
> > file, but I didn't even specify one.
> Can you please send me :
> a) the exact command line you are using
> b) the contents of the directory you are running it in
> c) the version or revision that you are testing
> Most likely you specified some file --hfile or --licence-text which
> would cause D4P to look for a file. If you did not specify those
> options, of if you did but those files exists, then there is a bug in
> my code.
> Please note that the newest version of the code is available by running
> hg clone http://dialog4ports.googlecode.com/hg/ dialog4ports
> If you are using version 12 or earlier (which can be found on
> isis.poly.edu) there are missing files from the package and it will
> not run.
> -- 
> Eitan Adler
> _______________________________________________
> freebsd-ports at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-ports
> To unsubscribe, send any mail to "freebsd-ports-unsubscribe at freebsd.org"


dialog4ports --port sysutils/pcpustat --option name=description="long description" --option second="second option"

dies if you press down arrow then up arrow, or tab twice.

In readying this to send to you, I tried shortening the descriptions, and
that makes it work.  Must be a buffer overrun somewhere, or unexpected

I tried this in the source directory itself, which contains:


I can send you the core file if that would be helpful (4MB).

uname -a:

FreeBSD libertas.local.camdensoftware.com 8.1-STABLE FreeBSD 8.1-STABLE #98: Tue Nov 16 10:41:17 PST 2010     sterling at libertas.local.camdensoftware.com:/usr/obj/usr/src/sys/LIBERTAS  amd64

Sterling (Chip) Camden    | sterling at camdensoftware.com | 2048D/3A978E4F
http://camdensoftware.com | http://chipstips.com        | http://chipsquips.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 488 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20101118/eb68bffe/attachment.pgp

More information about the freebsd-ports mailing list