[CFT] mplayer / mencoder port update

Michal Varga varga.michal at gmail.com
Sat Nov 13 01:18:24 UTC 2010


On Sat, 2010-11-13 at 03:22 +0300, Anonymous wrote:
> Can you try to replace
> 
>   #ifdef __FreeBSD__
> 
> with
> 
>   #ifdef __FreeBSD__ && __FreeBSD_version >= 800097
> 
> Alternatively, just hide the patch under ${OSVERSION} >= 800097.

Just my 2 cents:

Wouldn't be easier to simply made the patch optional via OPTIONS
(defaulting to off) and forget about it?

For example, I too have no use for it, as I don't prefer applications
messing with my mixer and thus run mplayer with -sotfvol. And seriously,
even then, for the past 10 years of pretty heavy mplayer usage - I
changed volume in it for like.. three times, ever (probably by
accident).

So for me, this is a patch that's not part of $Upstream, does absolutely
nothing I need, does even less for 4Front OSS users, and is already
known to break stuff for someone (the last point being somewhat
significant).

Please, don't include it by default for everyone.

m.

-- 
Michal Varga,
Stonehenge (Gmail account)




More information about the freebsd-ports mailing list