[www/chromium] Illegal instruction: 4 on Pentium3

Ruben chromium at hybridsource.org
Fri Nov 12 23:53:50 UTC 2010

On 11/12/2010 23:08, MIHIRA Sanpei Yoshiro wrote:
> Dear folks and chromium maintainer,
> I tried to compile www/chromium on Pentium3/FreeBSD-9-current box.
> But I could not compile it with below error message.
> ===>   Building for chromium-5.0.375.127
> <snip>
>    RULE sync_proto_genproto_0 out/Release/obj/gen/protoc_out/chrome/browser/sync/protocol/sync.pb.h
> gmake: *** [out/Release/obj/gen/protoc_out/chrome/browser/sync/protocol/sync.pb.h] Illegal instruction: 4 (core dumped)
> *** Error code 1
> So I tried to install package(chromium-5.0.375.127.tbz) from /pub/FreeBSD/ports/i386/packages-9-current/All. But I could not execute chromium.
> % chrome
> Illegal instruction (core dumped)
> If I install chromium on AMD athlon, I could use chromium.
> So is chromium not supported for Pentium3 CPU, only for Pentium 4 and later CPU?
> Or I could compile and execute with some setting for Pentium3 CPU?
Chromium requires sse2 normally, as detailed in this bug report:


I don't have PIII hardware to test: what you can do is 'make patch', 
then go into 
work/chromium-courgette-redacted-5.0.375.127/build/common.gypi and find 
these lines


and comment them out, then build as normal.  I think that should work. 
I don't know what ports normally does to support older hardware like 
this, but we can consider adding a patch for the 6.0 update if necessary:


More information about the freebsd-ports mailing list