[www/chromium] Illegal instruction: 4 on Pentium3

MIHIRA Sanpei Yoshiro sanpei at sanpei.org
Fri Nov 12 23:28:31 UTC 2010

Dear folks and chromium maintainer,

I tried to compile www/chromium on Pentium3/FreeBSD-9-current box.

But I could not compile it with below error message.

===>  Building for chromium-5.0.375.127
  RULE sync_proto_genproto_0 out/Release/obj/gen/protoc_out/chrome/browser/sync/protocol/sync.pb.h
gmake: *** [out/Release/obj/gen/protoc_out/chrome/browser/sync/protocol/sync.pb.h] Illegal instruction: 4 (core dumped)
*** Error code 1

So I tried to install package(chromium-5.0.375.127.tbz) from /pub/FreeBSD/ports/i386/packages-9-current/All. But I could not execute chromium.

% chrome
Illegal instruction (core dumped)

If I install chromium on AMD athlon, I could use chromium.

So is chromium not supported for Pentium3 CPU, only for Pentium 4 and later CPU?

Or I could compile and execute with some setting for Pentium3 CPU?

Best Regards,
MIHIRA, Sanpei Yoshiro
Tokyo, Japan.

More information about the freebsd-ports mailing list