USGS ISIS 3.2.1: build failure on FBSD 8.1/9.0 due to oudated xerxec-c2 ?

O. Hartmann ohartman at
Wed Nov 10 10:13:40 UTC 2010

On 11/09/10 22:06, O. Hartmann wrote:
> On 11/09/10 21:52, Gary Jennejohn wrote:
>> On Tue, 09 Nov 2010 20:34:48 +0100
>> "O. Hartmann"<ohartman at> wrote:
>>> Hello.
>>> Tried to build the newest ISIS 3.2.1 software package for planetary
>>> survey science, but fail. I always get the following error which seems
>>> to be triggered due to an ambiguous overload of a function, but I do not
>>> know how to fix the problem since everything seems clen to me. The USGS
>>> ISIS package uses prebuild libraries, but only for two Linux
>>> distributions and OSX, libxerces is version 3.1 as far as I can see, but
>>> FreeBSD port textproc/xerces-c2 is stuck with 2.7. So far, ISIS 3.2.0
>>> could be build on FreeBSD 8 and 9 with minor problems but working. Is
>>> anybody out here also utilising FreeBSD for scientific purposes and alsi
>>> using ISIS3 3.2.1? Can anybody help or give a hint?
>>> Thanks in advance,
>> Are you using the standard gcc? You could try installing one of the
>> gcc versions from ports and see whether that helps. The standard gcc
>> is a few generations old.
>> [snip error output]
> Hello,
> I'm using clang ;-) But I also tried gcc45. After I installed xerces-c
> version 3.1.1 from the Apache project in referred ISIS to take libs iand
> includes from the new installation path, I had success, but only a
> partial one. Xalan-c relies on the older version xerces-c2 2.7..
> I also tried with xerces-c2-devel (2.8.0), but it also produces the
> error shown prior to this message.
> Regards,
> Oliver

Some update.

I tried several compilers, all fail due to the wrong xerces-c library. 
The new USGS software package expects version 3.1.1 of xerces-c. Simply 
installing the new xerces-c library by compiling, installing to another 
path and referring to the new lib path etc. doesn't work properly, since 
there are some conflicts with the original installed xerces-c2 2.7 
library. I had to deinstall xerces-c2 package from the ports first, 
compile and install ISIS3, then reinstall xerces-c2 since it is 
neccessary by some other important ports we've installed. Xalan-c is 
also a candidate relying on xerces-c2, and a prerequisite for ISIS3, but 
so far, I did not recognize any conflicts or misbehaviour. But this is 
still a worse situation.


More information about the freebsd-ports mailing list