sane-backend 1.0.21 broke on 8.0?

Jason Naughton jason at
Fri Nov 5 20:33:48 UTC 2010

Hi all,

I have an epson perfection 1660 photo that worked beautiful under 6.0.  I
recently reinstalled a my laptop with 8.0:

FreeBSD 8.1-STABLE FreeBSD 8.1-STABLE #0: Fri Oct  8
17:37:37 EDT 2010    
root at  i386

It seems that /dev/uscanner has been dropped with the support of libusb. 
Now if I run sane-find-scanner as root or as user I get:

# sane-find-scanner -q

found USB scanner (vendor=0x04b8 [EPSON], product=0x011e [EPSON Scanner])
at libusb:/dev/usb:/dev/ugen3.2

Yet if I run

# scanimage -L

I get:

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Though even as scanimage -L fails to find the scanner I can run the command:

# scanimage -d epson --format=tiff > foo.tiff

and it works (the resolution is pretty crappy but it works).  If I attempt
to simply run:

# scanimage --format=tiff >foo2.tiff
scanimage: no SANE devices found

xsane fails to find anything so it won't start.  Any suggestions?  I've
been surfing the web but I haven't found anything as of yet.

Jason Naughton,  P.Eng, M.E.Sc,
Professional Contractor,
JMN Planning,  Pickering, Ontario,
Office: (416)-509-4886 Fax: (905)-831-3810

More information about the freebsd-ports mailing list