sane-backend 1.0.21 broke on 8.0?

Jason Naughton jason at
Fri Nov 5 20:33:48 UTC 2010

Hi All,

I recently reinstalled my laptop with Freebsd 8.X from 6.X:

FreeBSD 8.1-STABLE FreeBSD 8.1-STABLE #0: Fri Oct  8
17:37:37 EDT 2010    
root at  i386

Ever since I re-installed I haven't been able to work with my scanner
(EPSON perfection 1660 photo) which worked beautiful with 6.X.  It seems
that /dev/uscanner is no longer used with 8.X and libusb is now being
relied on to access usb devices.  The weird thing is that I can find the

$ sane-find-scanner -q
found USB scanner (vendor=0x04b8 [EPSON], product=0x011e [EPSON Scanner])
at libusb:/dev/usb:/dev/ugen3.2

as both user and root without any issues.  I can also use the scanner
again as user and root by issuing:

$ scanimage -d epson --format=tiff > foo.tiff

It seems though that scanimage cannot determine the scanner as it has to
be specified by the -d epson as if I issue:

$ scanimage --format=tiff > foo2.tiff
scanimage: no SANE devices found

which is also the same result from

$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Not sure why scanimage -L can't find it but sane-find-scanner does..  This
is the same results for root or user.  I would rather work with xsane as I
need to increase the resolution of the scan but that fails to find the
scanner and thus doesn't work at all.

Any ideas?

Jason Naughton,  P.Eng, M.E.Sc,
Professional Contractor,
JMN Planning,  Pickering, Ontario,
Office: (416)-509-4886 Fax: (905)-831-3810

More information about the freebsd-ports mailing list