opennms port

Greg Byshenk freebsd at byshenk.net
Tue Nov 2 15:02:36 UTC 2010


On Mon, Nov 01, 2010 at 08:37:10PM +0000, Sevan / Venture37 wrote:

> OpenNMS 1.8.5 port
> https://www.geeklan.co.uk/files/opennms/opennms-185-freebsd-port.tgz
> 
> As with previous versions, backup you existing opennms directory before upgrade.

It doesn't seem to work for me.

===

[...]

[INFO]   OpenNMS Base Assembly
[INFO]   OpenNMS Integration Tests
Downloading: http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-eclipse-plugin/2.5.1/maven-eclipse-plugin-2.5.1.pom
[WARNING] Unable to get resource 'org.apache.maven.plugins:maven-eclipse-plugin:pom:2.5.1' from repository maven-repo (http://repo1.maven.org/maven2): Invalid argument
Downloading: http://maven.opennms.org/content/groups/opennms.org-release/org/apache/maven/plugins/maven-eclipse-plugin/2.5.1/maven-eclipse-plugin-2.5.1.pom
[WARNING] Unable to get resource 'org.apache.maven.plugins:maven-eclipse-plugin:pom:2.5.1' from repository opennms-repo (http://maven.opennms.org/content/groups/opennms.org-release): Invalid argument
Downloading: http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-eclipse-plugin/2.5.1/maven-eclipse-plugin-2.5.1.pom
[WARNING] Unable to get resource 'org.apache.maven.plugins:maven-eclipse-plugin:pom:2.5.1' from repository central (http://repo1.maven.org/maven2): Invalid argument
Downloading: http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-eclipse-plugin/2.5.1/maven-eclipse-plugin-2.5.1.pom
[WARNING] Unable to get resource 'org.apache.maven.plugins:maven-eclipse-plugin:pom:2.5.1' from repository central (http://repo1.maven.org/maven2): Invalid argument
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).


Project ID: org.apache.maven.plugins:maven-eclipse-plugin

Reason: POM 'org.apache.maven.plugins:maven-eclipse-plugin' not found in repository: Unable to download the artifact from any repository

  org.apache.maven.plugins:maven-eclipse-plugin:pom:2.5.1

from the specified remote repositories:
  opennms-repo (http://maven.opennms.org/content/groups/opennms.org-release),
  central (http://repo1.maven.org/maven2),
  maven-repo (http://repo1.maven.org/maven2),
  opennms-snapshots (http://maven.opennms.org/content/groups/opennms.org-snapshot)

 for project org.apache.maven.plugins:maven-eclipse-plugin


[INFO] ------------------------------------------------------------------------
[INFO] Trace
org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project for plugin 'org.apache.maven.plugins:maven-eclipse-plugin': POM 'org.apache.maven.plugins:maven-eclipse-plugin' not found in repository: Unable to download the artifact from any repository

  org.apache.maven.plugins:maven-eclipse-plugin:pom:2.5.1

from the specified remote repositories:
  opennms-repo (http://maven.opennms.org/content/groups/opennms.org-release),
  central (http://repo1.maven.org/maven2),
  maven-repo (http://repo1.maven.org/maven2),
  opennms-snapshots (http://maven.opennms.org/content/groups/opennms.org-snapshot)

 for project org.apache.maven.plugins:maven-eclipse-plugin
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(DefaultLifecycleExecutor.java:1556)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.getMojoDescriptor(DefaultLifecycleExecutor.java:1744)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.segmentTaskListByAggregationNeeds(DefaultLifecycleExecutor.java:446)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:176)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:356)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:137)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:41)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:613)
        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.apache.maven.plugins:maven-eclipse-plugin': POM 'org.apache.maven.plugins:maven-eclipse-plugin' not found in repository: Unable to download the artifact from any repository

  org.apache.maven.plugins:maven-eclipse-plugin:pom:2.5.1

from the specified remote repositories:
  opennms-repo (http://maven.opennms.org/content/groups/opennms.org-release),
  central (http://repo1.maven.org/maven2),
  maven-repo (http://repo1.maven.org/maven2),
  opennms-snapshots (http://maven.opennms.org/content/groups/opennms.org-snapshot)

 for project org.apache.maven.plugins:maven-eclipse-plugin
        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:286)
        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:198)
        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:177)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(DefaultLifecycleExecutor.java:1539)
        ... 15 more
Caused by: org.apache.maven.project.ProjectBuildingException: POM 'org.apache.maven.plugins:maven-eclipse-plugin' not found in repository: Unable to download the artifact from any repository

  org.apache.maven.plugins:maven-eclipse-plugin:pom:2.5.1

from the specified remote repositories:
  opennms-repo (http://maven.opennms.org/content/groups/opennms.org-release),
  central (http://repo1.maven.org/maven2),
  maven-repo (http://repo1.maven.org/maven2),
  opennms-snapshots (http://maven.opennms.org/content/groups/opennms.org-snapshot)

 for project org.apache.maven.plugins:maven-eclipse-plugin
        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:605)
        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:270)
        ... 18 more
Caused by: org.apache.maven.artifact.resolver.ArtifactNotFoundException: Unable to download the artifact from any repository

  org.apache.maven.plugins:maven-eclipse-plugin:pom:2.5.1

from the specified remote repositories:
  opennms-repo (http://maven.opennms.org/content/groups/opennms.org-release),
  central (http://repo1.maven.org/maven2), 
  maven-repo (http://repo1.maven.org/maven2),
  opennms-snapshots (http://maven.opennms.org/content/groups/opennms.org-snapshot)


        at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:228)
        at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:90)
        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:558)
        ... 20 more
Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: Unable to download the artifact from any repository
        at org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:349)
        at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:216)
        ... 22 more
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 8 seconds
[INFO] Finished at: Tue Nov 02 15:28:36 CET 2010
[INFO] Final Memory: 25M/61M
[INFO] ------------------------------------------------------------------------
*** Error code 1

Stop in /usr/ports/net-mgmt/opennms.

===

I seem to be able to reach 

   http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-eclipse-plugin/2.5.1/maven-eclipse-plugin-2.5.1.pom

... but I get an .xml page instead of the .pom.


-- 
greg byshenk  -  gbyshenk at byshenk.net  -  Leiden, NL


More information about the freebsd-ports mailing list