xfce4/xorg problem amd64

Sandra Kachelmann s.kachelmann at googlemail.com
Wed May 19 13:56:07 UTC 2010


Hi

Since the xorg update my xfce4 desktop has become unusable. I always
get the error message below. I even setup FreeBSD 8.0-RELEASE from
scratch, updated to 8.0-STABLE, installed xorg and xfce4 with default
settings:

$ portinstall --batch /usr/ports/x11/xorg /usr/ports/x11-wm/xfce4

Then I moved my homedir away to avoid any cruft in .config or
wherever. Setup .ininitrc .session

$ cat .xinitrc
if [ -f ~/.xsession ]; then
        . ~/.xsession
fi

$ cat .xsession
cd
xset b off
/usr/local/bin/numlockx
exec sh /usr/local/etc/xdg/xfce4/xinitrc

So now everything should be completely vanilla:

skachelmann at valhalla:~ $ startx
xauth:  creating new authority file /home/skachelmann/.serverauth.7426


X.Org X Server 1.7.5
Release Date: 2010-02-16
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 8.0-STABLE amd64
Current Operating System: FreeBSD valhalla.local 8.0-STABLE FreeBSD
8.0-STABLE #0: Fri May  7 20:43:11 CEST 2010
root at valhalla.local:/usr/obj/usr/src/sys/GENERIC amd64
Build Date: 19 May 2010  12:50:03AM

Current version of pixman: 0.16.6
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed May 19 15:41:10 2010
(==) Using config file: "/etc/X11/xorg.conf"
record: RECORD extension enabled at configure time.
record: This extension is known to be broken, disabling extension now..
record: http://bugs.freedesktop.org/show_bug.cgi?id=20500
<stdin>:1:3: error: invalid preprocessing directive #Those
<stdin>:2:3: error: invalid preprocessing directive #or
<stdin>:3:3: error: invalid preprocessing directive #Xft
<stdin>:4:3: error: invalid preprocessing directive #Xft
xrdb:  "Xft.hinting" on line 9 overrides entry on line 6
xrdb:  "Xft.hintstyle" on line 11 overrides entry on line 7
xfdesktop[7480]: starting up
process 7466: arguments to dbus_message_new_signal() were incorrect,
assertion "_dbus_check_is_valid_path (path)" failed in file
dbus-message.c line 1165.
This is normally a bug in some application using the D-Bus library.
  D-Bus not compiled with backtrace support so unable to print a backtrace
Abort trap (core dumped)

(xfce4-settings-helper:7482): libxfcegui4-WARNING **: ICE I/O Error

waiting for X server to shut down
(xfce4-settings-helper:7485): xfce4-settings-helper-WARNING **: Failed
to connect to session manager
xfce4-settings-helper: Fatal IO error 53 (Software caused connection
abort) on X server :0.0.
xfwm4: Fatal IO error 2 (No such file or directory) on X server :0.0.
xfce4-panel: Fatal IO error 0 (Unknown error: 0) on X server :0.0.



dbus and hal are running.

Any help to solve this nightmare is gratefully appreciated!

Sandra


More information about the freebsd-ports mailing list