graphics/libchamplain build failure ( not found)

Ruslan Mahmatkhanov cvs-src at
Sun May 16 06:24:14 UTC 2010

16.05.2010 08:30, Doug Barton пишет:
> On 5/15/2010 8:56 PM, Christer Edwards wrote:
>> On Sat, May 15, 2010 at 4:51 PM, Jason<jhelfman at>  wrote:
>>> I ran into this as well, and after completely removing libchamplain, and
>>> doing a rebuild on all libraries needing png, this port installed with no
>>> issue and built against, as expected.
>> I'm having a similar issue, although not with libchamplain. Can you
>> comment regarding how you rebuilt all libraries needing png? I've been
>> trying to force-rebuilds of ports, but I'm still getting complaints
>> for applications needing
> I posted the following already which should tell you what libs you're
> missing, and what you need to rebuild, did you not see my message?

Thanks Doug!
Sorry for delay, we had a night time there.
The only library that depend on (apart from, and was 
the that expose a bunch of gir-repository-* 
ports that should be deinstalled in favor to other ports. F.e:
gir-repository-gtk20 -> gtk20
gir-repository-pango -> pango


So i deinstall them all and rebuilt all the libchamplain run and build 
dependecies (atk, gtk, pango, glib etc). After all of that libchamplain 
still doesn't builds with the same error. This is my old-lib-list after 
all the rebuilding work:

[mrk at smeshariki2 ~]> cat old-lib-list
/usr/local/lib/ => not found (0x0)

/usr/local/lib/ => not found (0x0)

/usr/local/lib/ => not found (0x0) => not found (0x0)

/usr/local/lib/ => not found (0x0) => not found (0x0)

/usr/local/lib/ => not found (0x0) => not found (0x0) => not found (0x0)

/usr/local/lib/ => not found (0x0) => not found (0x0) => not found (0x0)

> for file in /usr/local/lib/*; do
> 	nf=`ldd $file 2>/dev/null | grep 'not found'`
> 	if [ -n "$nf" ]; then
> 		echo $file
> 		echo $nf
> 		echo ''
> 	fi
> done>  ~/old-lib-list


More information about the freebsd-ports mailing list