Status of Xorg 7.5 and xfce4?

Torfinn Ingolfsen tingox at
Sat May 8 10:16:55 UTC 2010


On Fri, May 7, 2010 at 8:42 PM, Richard Kuhns <rjk at> wrote:

> On 05/05/10 13:07, Warren Block wrote:
>> On Wed, 5 May 2010, Ondrej Majerech wrote:
>> After a reboot, and not having attempted to start X or xfce...
>> mkdir ~/backup
>> mv ~/.config ~/backup
>> startxfce4 (or startx if .xinitrc starts xfce4)
>> xfce starts with defaults.
>> Click "quit" button in panel, or right-click desktop,
>>    Applications/Log Out.
>> Click "Log Out".
>> rm -rf ~/.config (this is the new copy just created by xfce).
>> mv ~/backup/.config ~
>> After that, xfce starts every time.  Or at least every time I've
>> tried--20 times in a row on one system.  And it's worked on two systems.
>> Now why it worked...
I tried that - it didn't work for me.

I'll make it even more interesting now.
> I tried this with no joy. However, when I moved my original .config back in
> place and tried again I actually saw my desktop for approximately 1 second
> before the crash-n-burn. That made me think there was possibly a timing
> problem (what did I have to lose?). I copied the default xinitrc
> (/usr/local/etc/xdg/xfce4/xinitrc) to ~/.config/xfce4 and added a 'sleep 5'
> immediately before the attempt to execute xfce4-session:
> --- /usr/local/etc/xdg/xfce4/xinitrc    2010-04-30 10:09:28.000000000 -0400
> +++ /home/rjk/.config/xfce4/xinitrc     2010-05-07 10:35:38.000000000 -0400
> @@ -131,6 +131,7 @@
>        x|xno*)
>                ;;
>        *)
> +               sleep 5
>                $xfcesm
>                if test $kill_sshagent -eq 1; then
> This seems to have fixed it; my desktop is back to normal. I'm at 4 for 4,
> at any rate.

I tried this too, it didn't work for me.

My system:
root at kg-v7# uname -a
FreeBSD 8.0-STABLE FreeBSD 8.0-STABLE #1: Fri Mar 12 19:56:45
CET 2010     root at  amd64
root at kg-v7# sysctl hw.model
hw.model: Intel(R) Core(TM) i3 CPU         540  @ 3.07GHz
root at kg-v7# pciconf -lv | grep -A 3 vga
vgapci0 at pci0:0:2:0:    class=0x030000 card=0x83831043 chip=0x00428086
rev=0x12 hdr=0x00
    vendor     = 'Intel Corporation'
    class      = display
    subclass   = VGA

and using the 'vesa' driver in xorg.conf (the 'intel' driver doesn't work
with the integrated GPU in this i3 Core cpu).
When I try to use the intel driver, I get these error lines in
(EE) intel(0): [drm] Failed to open DRM device for pci:0000:00:02.0: File
(EE) intel(0): Failed to become DRM master.
(EE) intel(0): No valid modes.

startx work fine for both normal and root user, startxfce4 does not.
If I deinstall xfce4-session, startxcfe4 works again (both as normal and
root user)

More information about the freebsd-ports mailing list