UPDATING entry for X.org changes

Freddie Cash fjwcash at gmail.com
Fri May 7 15:55:32 UTC 2010

On Fri, May 7, 2010 at 6:44 AM, Guido Falsi <mad at madpilot.net> wrote:

> On Fri, May 07, 2010 at 02:20:55PM +0200, Ren Ladan wrote:
> > 2010/5/7 Robert Huff <roberthuff at rcn.com>:
> > >
> > >        Is there one?  I've been checking daily, and ... nothing.
> > > (Various sited, including just now "cvsup.freebsd.org:.)
> > >
> > >
> > No, there is indeed none for now.
> >
> > If you use portmaster you can just run 'portmaster -af' or follow the
> > instructions near the end of its manual page (before Doug Barton
> > goes correcting me ;) )
> Why are you using "-af" forcing eqach and every port to be updated? I've
> just done it with "portmaster -a" and weverything just works(I was
> surprised too).
> Am I missing some important point which will look obvious tyo everyone
> reading this email? :)
> What would have been nice is a note that the default background for the
bare X server was changed from the nice grey/black checkerboard to solid

The portmaster update of X completed successfully.  Starting X by itself (X
-config /etc/X11/xorg.conf) gave a black screen, like it had crashed.  Tried
"X -configure" and "X -config ./xorg.conf.new".  Same thing.  Tried a couple
of different xorg.conf files, tried without a config file.  All gave black
screens, similar to a crash of the X server or a driver bug.

Deleted every port on the system and did a clean install of just xorg.  Same
thing, black screen.  On a whim, I tried "xinit /usr/local/bin/xterm"  ...
...  ... and saw a black screen with a tiny xterm in the corner.  Great ...
so things were working from the get go.

So, after 2 days of compiling, I have a barebone KDE4 desktop running on
Xorg 7.5, with at least another 2 days of compiling before things are back
to where they were originally.  :(

At least that should be noted in UPDATING.

Freddie Cash
fjwcash at gmail.com

More information about the freebsd-ports mailing list