portmaster stopped finding dependent ports if non-standard PORTSDIR

John Marshall john.marshall at riverwillow.com.au
Thu May 6 01:59:00 UTC 2010

Yesterday I updated ports on my notebook (8.0-RELEASE-p2), took a deep
breath, used portmaster to upgrade xorg to 7.5 (portmaster -D xorg-7.4_4)
- ran without a hitch.

Then, I upgraded portmaster (portmaster -D portmaster) - also no

Then, I tried to upgrade jpeg...

rwpc08# portmaster -D jpeg

===>>> Currently installed version: jpeg-8_1
===>>> Port directory: /usr/ports/graphics/jpeg
===>>> Launching 'make checksum' for graphics/jpeg in background
===>>> Gathering dependency list for graphics/jpeg from ports
===>>> Starting recursive 'make config' check
===>>> Launching child to update /build/ports/devel/libtool22
	jpeg-8_1 >> /build/ports/devel/libtool22

===>>> No valid installed port, or port directory given
===>>> Try portmaster --help

===>>> Update for /build/ports/devel/libtool22 failed
===>>> Aborting update


rwpc08#	pkg_info -Ex libtool
rwpc08#	pkg_info -qox libtool
rwpc08#	ls -l /usr/ports/devel/libtool22/
total 10
-rw-r--r--  1 root  wheel   701 Dec  7 10:32 Makefile
-rw-r--r--  1 root  wheel   200 Dec  7 10:32 distinfo
drwxr-xr-x  2 root  wheel   512 Dec  7 10:32 files
-rw-r--r--  1 root  wheel   305 Aug  3  2009 pkg-descr
-rw-r--r--  1 root  wheel  1853 Aug  3  2009 pkg-plist
rwpc08#	ls -ld /usr/ports
lrwxr-xr-x  1 root  wheel  12 Nov 23 18:21 /usr/ports -> /build/ports
rwpc08#	grep PORTSDIR /etc/make.conf
PORTSDIR=	/build/ports

I've tried upgrading other ports as well: same story.  portmaster 2.25
seems to work fine on other systems which have a native /usr/ports.  I'm
thinking that portmaster's non-standard location awareness may have
broken with some of the recent ORIGIN stuff?  The version of portmaster
I used to upgrade xorg was 2.2x (I think 2.22): I remember noticing that
it was 2 or 3 releases behind.

Thanks again for providing this great utility.

John Marshall
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 196 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20100506/e1a4aab7/attachment.pgp

More information about the freebsd-ports mailing list