Samuel Martín Moro faust64 at gmail.com
Tue Mar 23 09:41:10 UTC 2010


So, I tested ntfsresize (not everything, but mainly)
It seems to work.
As I though, it uses the functions I patched for mkntfs, in order to get
device geometry.

I have that USB key, 4Gb.
fdisk (linux, I use the freebsd one for scripting, but, honestly, linux one
is way easier to use), to create a NTFS primary partition on the whole
Back to BSD, mkntfs -f /dev/da1s1
Now, ntfsresize /dev/da1s1 -s 3G

It seems to work, but I didn't search that much for clues...
To be sure, I'ld like to change the partition table, but I'ld need to know
exactly where to end/start my new partitions. Not in the mood for that kind
of maths.

Anyway, an other way to test was to create two partitions, format the first
one, then delete the second partition and expand the first one to the whole
drive, and run ntfsresize.
And well, it worked. I had my first partition of 1Gb, working fine, and then
I resized it to 4Gb, without any kind of troubles.

I still didn't look at the $UpCase problem.
I may do it quickly.


Samuel Martín Moro
{EPITECH.} tek4
CamTrace S.A.S

On Thu, Mar 18, 2010 at 6:00 PM, Samuel Martín Moro <faust64 at gmail.com>wrote:

> I already tested ntfsprogs1.
> I don't remember wich version exactly (found it with portdowngrade), nor
> what were its problems.
> But, it was for work.
> We just wanted to be able to mount/write and format devices with ntfs
> partitions.
> And we weren't able to.
> It might be that I didn't think to try without libublio support (don't
> remember, I'm not even sure ublio is used in the first version).
> It may be usefull to get back the first version in ports, sure.
> But there's not that much things to adapt in the current version.
> The problem is that the person who made that port just copied the package
> from linux, without porting it.
> The modifications I made were very easy to find out, every
> C developer should be able to do them quickly, putting some printf.
> I don't have FreeBSD at home, I'm just working on it at office. And
> patching ArchLinux at home.
> I might not be able to finish patching ntfsprogs2 to make it completly work
> on FreeBSD.
> The good news is that, with my patch to ntfslib, ntfsresize should now be
> able to get the geometry of a device.
> Maybe that was its only problem, and so it's working again?
> I'll give it a try next monday.
> Cheers,
> Samuel Martín Moro
> {EPITECH.} tek4
> CamTrace S.A.S
> On Thu, Mar 18, 2010 at 3:17 PM, Jan Henrik Sylvester <me at janh.de> wrote:
>> As you are working on ntfsprogs, are you able to use ntfsresize at all?
>> For me, ntfsresize never worked in ntfsprogs-2.0.0, but it did in
>> ntfsprogs-1.13.1. We had a discussion about ntfsprogs on freebsd-questions
>> almost a year ago:
>> http://lists.freebsd.org/pipermail/freebsd-questions/2009-April/thread.html#196207
>> I still do not know more than I stated in there:
>> http://lists.freebsd.org/pipermail/freebsd-questions/2009-April/196252.html
>> I still would like to create an ports/ntfsprogs1 (back)port to get
>> ntfsprogs-1.13.1 back. Unfortunately, I have not had time to do this since
>> then.
>> Maybe you want to check yourself, if 1.13.1 gives less problems than
>> 2.0.0...
>> Although ntfsprogs is not maintained anymore, mkntfs and ntfsresize are
>> still useful -- thus picking the best last release and fixing that on
>> current FreeBSD may be worse it.
>> Cheers,
>> Jan Henrik

More information about the freebsd-ports mailing list