Keyboard problem on upgraded to kde 4.3.5 with system crash - help

David Southwell david at
Mon Mar 1 12:09:52 UTC 2010

Thanks in advance for any help

I reported problems following an upgrade ro 4.3.5 in a previous thread:
kde4 Upgrade to 4.3.5 -problems 

The major problem was solved BUT I am now left without a working keyboard
although the mouse works.

After kde4 loaded with usual plasmas but no keyboard input was possible
despite the following entries  in /etc/rc.conf


I would experiment so I plugged in an another keyboard (this time on the USB
bus). Tested that that worked on a normal console and then

% startx

produced a total system crash!

I removed the additional keyboard, & after booting to single user mode and
running fsck tried startx again.

Kde started fine. However still no keyboard function.

Logged out and tried 
% startx 
again -- system crashed again!!!. 
So the crash does not seem to have anything to do with the second keyboard
but a lot to do with logging out of X and trying to log in again.

Does anyone have any clue here?

Again this is freebsd 7.2 p3 amd64 on intel quad core.

Thanks in advance


More information about the freebsd-ports mailing list