graphics/png does not compile with gcc 4.5.1

Doug Barton dougb at
Wed Jun 30 06:41:26 UTC 2010

On Tue, 29 Jun 2010, Doug Barton wrote:

> One more question. Is your gcc compiled with the LTO option? 
> (/var/db/ports/gcc*/options will tell you.) I had that enabled (it's off by 
> default) so I'm going to try recompiling gcc without it and see if it helps.

Never mind, compiling without the LTO option didn't help.

I had the following libmap.conf entries:   gcc45/    gcc45/    gcc45/     gcc45/  gcc45/

I commented all of those out, went into /lib and /usr/lib and moved the 
base versions of the libraries out of the way, ran ldconfig -R, made 
sure that /usr/local/lib/gcc45/ is the only ssp library, and 
then tried again, same error. The symbol appears to be in the lib:

nm | grep __stack_chk_fail_local
00000ac0 t __stack_chk_fail_local

So I'm at a loss, and pretty close to throwing in the towel and going 
back to the base gcc for everything.



 	Improve the effectiveness of your Internet presence with
 	a domain name makeover!

 	Computers are useless. They can only give you answers.
 			-- Pablo Picasso

More information about the freebsd-ports mailing list