lang/perl5.10 doesn't build with gcc 4.5.1

Doug Barton dougb at FreeBSD.org
Sat Jun 19 23:45:11 UTC 2010


On 06/19/10 08:25, b. f. wrote:
> lang/perl5.* fails with -fstack-protector in CFLAGS, when built with
> the base system compiler, on some architectures. I used the attached
> patch with the base system compiler and lang/perl5.10 on 9-CURRENT
> i386 to fix the problem.  However, I never attempted to use it with
> lang/gcc45, because I did not want to introduce circular dependencies
> in my ports.  Your problem may be related.

I tried your patch, didn't help. I got the same error as previously. 
Thanks for trying though. :)


Doug

-- 

	... and that's just a little bit of history repeating.
			-- Propellerheads

	Improve the effectiveness of your Internet presence with
	a domain name makeover!    http://SupersetSolutions.com/



More information about the freebsd-ports mailing list