Build of sysutils/polkit, sysutils/policykit, docbook-410 Problem

Ralf Folkerts ralf.folkerts at
Sat Jan 23 10:32:19 UTC 2010


I just updated my Ports-Tree and tried to rebuild sysutils/policykit (to 
0.9_6) and sysutils/polkit (to 0.96_1) as per UPDATING.

However, I ran into a Problem, because both wanted to Install 
docbook-410 4.1_4) which was installed and up-to-date already.

It seems, that policykit and polkit expect

                 xsltproc:${PORTSDIR}/textproc/libxslt \

                 xsltproc:${PORTSDIR}/textproc/libxslt \

/usr/local/share/sgml/docbook/4.1/catalog, while docbook-410 (4.1_4) 


the catalog into the dtd Subdir.

The Result is... (it's the same for polkit)

[-su]beaster:~$cd /usr/ports/sysutils/policykit
===>  Extracting for policykit-0.9_6
=> MD5 Checksum OK for PolicyKit-0.9.tar.gz.
=> SHA256 Checksum OK for PolicyKit-0.9.tar.gz.
===>  Patching for policykit-0.9_6
===>  Applying FreeBSD patches for policykit-0.9_6
===>   policykit-0.9_6 depends on file: 
/usr/local/share/sgml/docbook/4.1/catalog - not found
===>    Verifying install for /usr/local/share/sgml/docbook/4.1/catalog 
in /usr/ports/textproc/docbook-410
===>  Extracting for docbook-4.1_4
=> MD5 Checksum OK for
=> SHA256 Checksum OK for
===>   docbook-4.1_4 depends on file: /usr/local/bin/unzip - found
===>  Patching for docbook-4.1_4
===>  Configuring for docbook-4.1_4
===>  Installing for docbook-4.1_4
===>   docbook-4.1_4 depends on file: 
/usr/local/share/sgml/iso8879/catalog - found
===>   docbook-4.1_4 depends on file: /usr/local/bin/xmlcatmgr - found
===>   Generating temporary packing list
===>  Checking if textproc/docbook-410 already installed
===>   docbook-4.1_4 is already installed
       You may wish to ``make deinstall'' and install this port again
       by ``make reinstall'' to upgrade it properly.
       If you really wish to overwrite the old port of textproc/docbook-410
       without deleting it first, set the variable "FORCE_PKG_REGISTER"
       in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/textproc/docbook-410.
*** Error code 1

Stop in /usr/ports/sysutils/policykit.

I circumvented this by changing the BUILD_DEPENDS Makefiles for 
policykit and polkit





However, as I have no clue who's correct (the pol.*kit Makefiles by 
assuming "catalog" in /share/sgml/docbook/4.1/ or the docbook-410 who 
installs into the dtd Subdir) it would be cool if someone could check 

Btw: This is on

FreeBSD 7.2-STABLE FreeBSD 7.2-STABLE #0: Fri Dec 11 22:19:58 CET 2009 
/usr/obj/usr/src/sys/GENERIC  amd64


More information about the freebsd-ports mailing list