java in a browser (was: Re: [CFT] Firefox 3.6 for FreeBSD)

Juergen Lock nox at
Wed Feb 24 21:21:32 UTC 2010

In article <20100205091256.GA97892 at> you write:
>On Fri, Feb 05, 2010 at 09:27:49AM +0100, Dominic Fandrey wrote:
>> Greg Lewis wrote:
>> > On Fri, Feb 05, 2010 at 07:48:37AM +1100, Peter Jeremy wrote:
>> >> On 2010-Feb-04 01:19:33 +0100, Martin Wilke <miwi at> wrote:
>> >>> The problem was that starting Firefox 3.6 with certain
>> >>> addons installed was not possible. Now it looks like all
>> >>> problems are solved and we can start a CFT.
>> >> Thanks to all for your efforts.
>> >>
>> >>> weekend. We should also note that the java plugin currently
>> >>> does not work with 3.6.
>> >> This is a blocker for me.  What is involved in building a
>> >> java plugin to suit the new FF36 interface?  Please let me know
>> >> if there's anything I can do to assist the effort.
>> > 
>> > Well, I don't believe the java plugin works with Firefox 3.5, so this isn't
>> > a new development.
>> You are mistaken here, the Java plugin works fine with firefox35.
>Hmm.  So I've got the plugin installed from the current diablo-jre16 port
>and firefox35 doesn't find it.  What does your set up look like?  For me
>> ls -l /usr/local/lib/browser_plugins/ 
>lrwxr-xr-x  1 root  wheel  63 Nov  8 10:50 /usr/local/lib/browser_plugins/ -> /usr/local/diablo-jre1.6.0/plugin/i386/ns7/
>Are you using it from jdk16 perhaps?
>> A real annoyance is that the OpenJDKs don't build the plugin, you
>> need one of the SUN or Diablo JDKs.
>They don't build it because Sun doesn't include it...

Btw I meanwhile found a kind of `workaround' until we have a new sun jdk
or icedtea port:  konqueror (both the kde3 and the kde4 versions) runs
java applets via a normal `java' executable (and apparently its own ipc
wrapper code), so it doesn't need a plugin.  And this also means it
even works with openjdk7 (and linux-sun-jdk in a native browser), at
least it did for me doing a simple test on
after setting either JAVA_HOME or configuring a full path in
settings -> konqueror -> java and javascript -> path to java executable.

 All of these worked for me:

zsh triton8% ll /usr/local/*/bin/java
-rwxr-xr-x  1 root  wheel  95014 May 13  2008 /usr/local/diablo-jdk1.6.0/bin/java*
-rwxr-xr-x  1 root  wheel  47308 Oct 11 10:40 /usr/local/linux-sun-jdk1.6.0/bin/java*
-r-xr-xr-x  1 root  wheel  60214 Feb 13 06:15 /usr/local/openjdk7/bin/java*
zsh triton8%

 HTH, :)

More information about the freebsd-ports mailing list