FreeBSD Ports Problem - Please help

M M 77superchimp at
Fri Feb 12 04:54:08 UTC 2010

Greetings from the Louisville, Kentucky! My name is Murphy McAllister. I am
writing this email in need of help/advice with FreeBSD, specifically with
fixing my ports.

If you would be so kind, here is my problem.

I currently have FreeBSD 8.0 RELEASE installed on my Pentium 4 box.

I installed it and then configured it with KDE 3.5.10 and for a while
everything was great. Everything ran fantastic. Then one day I tried to
install and configure an image scanner that we had. This is where I ran into

I followed the FreeBSD guidebook and tried to install the ports
'graphics/sane-backends' and 'graphics/sane-frontends', but when I did this,
FreeBSD told me I needed the latest installation of graphics/jpeg (which
happened to be jpeg-8, and I only had jpeg-7 installed on my machine).

So If I remember correctly, I ended up using *Portupgrade* for this process.
I believe I ran 'Portupgrade -ai' which took quite a long time. Portupgrade
worked great or whatever Port updating command I ran did a wonderful updated the graphics/jpeg port on my machine.

But unfortunately, jpeg-8 has broken KDE as well as X11. I found this out
when I rebooted my machine. KDE no longer ran on my machine, and X11 was
also broken as well. I had KDM configured to handle the login, but instead
of getting KDM on ttyv8, I received an error message on ttyv0 "*getty
repeating* *too quickly on port /dev/ttyv8, sleeping 30 secs*" and this
would repeat over and over indefinitely.

Here are some error messages I receive:

When running the 'startx' command:
from the GUI:
A window surround by black saying "Could not start kstartupconfig. Check
your installation." After closing the window, another window appeared: "Call
to lnusertemp failed (temporary directories full?). Check your

from the console:
libexec/ Shared object "" not found, required by
libexec/ Shared object "" not found, required by
libexec/ Shared object "" not found, required by

So if I'm not mistaken, I then ran portmanager ( or possibly portupdate) and
tried doing a total update of:

1. X11/xorg (and recursively all its dependencies)
2. X11/kde3 (and recursively all its dependencies)

This took a total of about 2 days to install both of these. Unfortunately,
and to my dismay, it did not fix the problem. I still got the exact same
error messages when rebooting.

So then I decided to try to get jpeg-7 back on my machine (as I was thinking
that the jpeg-8 installed port was what was giving me the problem). I was
able to do put the old port snapshot back on my machine via my 8.0 RELEASE
installation disk via the sysinstall method. I then went to the
/usr/ports/graphics/jpeg directory and did a 'make install clean'. It
installed the old jpeg port fine.

But alas, KDM still does not come up after rebooting (I get an error message
saying that ('kdm-bin: :0[1142]: Abnormal termination of greeter for display
:0, code 1, signal 0') and  now when I run startx I get the error message:
("/libexec/ Shared object '' not found, required by
'' ") and ("startkde: Could not start kdeinit. Check you
installation). I do however, get the black screen and can see my cursor.
When I test X11 the old fashioned way (Xorg -config -retro) I
get a nice grey screen as expected, with a nice X for my cursor that moves
as expected and no error messages. So it would seem that X11 might be close
to being OK.

I have tried to now get the jpeg-8 port installed again but I have been
unsuccessful. I have run portupgrade jpeg as well as tried portmaster but
they don't upgrade to the jpeg-8 port.

Any advice would be greatly appreciated. At this point I am waiving the
white flag and I would love to just get back to my original configuration
and forget about installing the image scanner. Above all else, I am just
trying to avoid a total reinstall of FreeBSD 8.0.

My last idea is to install jpeg-8 and then cp the existing
file to the same directory as and run this command:

ln -s /usr/local/lib/ /usr/local/lib/

I found out this might be a possible solution from doing research through

But I understand this may not be work and/or it may not be the best road to
take. And advice and/or instructions would greatly be appreciated!

Thank you so much for your time! :)

Best Regards,

More information about the freebsd-ports mailing list