[WORKAROUND] Re: /usr/ports/x11-toolkits/qt33: /usr/bin/ld: warning: libjpeg.so.10, needed by /usr/local/lib/libqt-mt.so, not found (try using -rpath or -rpath-link)

Franci Nabalanci lumiwa at gmail.com
Sat Feb 6 13:53:06 UTC 2010


There is a new jpeg 8 and you need to rebuild with for example portmaster -r
jpeg-\* if you use a portmaster (there are instructions in
/usr/ports/UPDATING).

But antwhere I have a problem with arts where I get an error 1. I am trying
again and will sent what kind of error I got.


On Sat, Feb 6, 2010 at 4:58 AM, Ion-Mihai Tetcu <itetcu at freebsd.org> wrote:

> On Sat, 6 Feb 2010 12:49:52 +0200
> Ion-Mihai Tetcu <itetcu at FreeBSD.org> wrote:
>
> > On Sat, 06 Feb 2010 11:13:08 +0100
> > "O. Hartmann" <ohartman at mail.zedat.fu-berlin.de> wrote:
> >
> > > Since yesterday's portsnape and attempt updating my ports, ALL
> > > FreeBSD boxes (running FreeBSD 8.0/amd64) fail to update ports via
> > > 'portmaster -av' at the same point with the following error.
> > >
> > > It seems that that port jpeg-8 has been updated and now offering
> > > libjpeg.so.11 instead of the desired old libjpeg.so.10, so I guess
> > > everything depending on port jpeg-8 needs to be rebuild - but
> > > ports/UPDATE does not reflect this.
> > >
> > > c++ -fno-exceptions  -Wl,-rpath,/usr/local/lib
> > > -Wl,-rpath,/usr/local/lib -pthread -o ../../../bin/uic
> > > .obj/release-shared-mt/main.o  .obj/release-shared-mt/uic.o
> > > .obj/release-shared-mt/form.o  .obj/release-shared-mt/object.o
> > > .obj/release-shared-mt/subclassing.o  .obj/release-shared-mt/embed.o
> > > .obj/release-shared-mt/widgetdatabase.o
> > > .obj/release-shared-mt/domtool.o  .obj/release-shared-mt/parser.o
> > > -L/usr/local/lib -L/usr/local/lib
> >
> > ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> >
> > > -L/usr/ports/x11-toolkits/qt33/work/qt-x11-free-3.3.8/lib
> > > -L/usr/local/lib -lqt-mt -lmng -ljpeg -lpng -lz -lXi -lXrender
> > > -lXrandr -lXcursor -lXinerama -lXft -lfreetype -lfontconfig -lXext
> > > -lX11 -lm -lSM -lICE
> > > /usr/bin/ld: warning: libjpeg.so.10, needed by
> > > /usr/local/lib/libqt-mt.so, not found (try using -rpath or
> > > -rpath-link) /usr/local/lib/libqt-mt.so: undefined reference to
> > > `jpeg_start_decompress at LIBJPEG_7.0'
> >
> >
> > That above it's the problem, kde team is aware of it.
> >
> > For the moment the workaround, when you get to this, is to:
> > mv /usr/local/lib/libqt-mt.so /usr/local/lib/libqt-mt.so.old && \
> > cd /usr/ports/x11-toolkits/qt33/ && make && \
> > mv /usr/local/lib/libqt-mt.so.old /usr/local/lib/libqt-mt.so && \
> > portmaster -C x11-toolkits/qt33
> >
> >
> > I did this yesterday while under KDE3 without problems.
>
> You'll run into the same kind of problem with kdelibs3:
>
>
> Making all in dnssd
> gmake[2]: Entering directory
> `/usr/home/itetcu/wrk/usr/ports/x11/kdelibs3/work/kdelibs-3.5.10/dnssd'
> ../kdecore/kconfig_compiler/kconfig_compiler ./kcm_kdnssd.kcfg
> ./settings.kcfgc; ret=$?; \
>        if test "$ret" != 0; then rm -f settings.h ; exit $ret ;  fi
> /libexec/ld-elf.so.1: Shared object "libjpeg.so.10" not found, required by
> "libkdefx.so.6"
> gmake[2]: *** [settings.h] Error 1
> gmake[2]: Leaving directory
> `/usr/home/itetcu/wrk/usr/ports/x11/kdelibs3/work/kdelibs-3.5.10/dnssd'
> gmake[1]: *** [all-recursive] Error 1
> gmake[1]: Leaving directory
> `/usr/home/itetcu/wrk/usr/ports/x11/kdelibs3/work/kdelibs-3.5.10'
> gmake: *** [all] Error 2
> *** Error code 1
>
> Stop in /usr/ports/x11/kdelibs3.
>
>
> The same workaround works.
>
> And yes, this means the kde ports are in wrong.
>
>
> --
> IOnut - Un^d^dregistered ;) FreeBSD "user"
>  "Intellectual Property" is   nowhere near as valuable   as "Intellect"
> FreeBSD committer -> itetcu at FreeBSD.org, PGP Key ID 057E9F8B493A297B
>


More information about the freebsd-ports mailing list