clive

ajtiM lumiwa at gmail.com
Thu Dec 30 12:05:39 UTC 2010


On Wednesday December 29 2010 18:31:17 Peter Jeremy wrote:

> 
> I'd check:
> 1) 'pkg_info -g -a' doesn't report problems
> 2) PERL_VERSION in /etc/make.conf is correct
> 3) 'perl -V' output is correct.
> 
> If you can't track down the problem, you might need to reinstall
> perl and all p5-* ports.

I am sorry...I forgot to wrote which clive. Yes, it is multimedia/clive.

Mitjaperl -V
Summary of my perl5 (revision 5 version 8 subversion 9) configuration:
  Platform:
    osname=freebsd, osvers=8.0-release-p4, archname=i386-freebsd-64int
    uname='freebsd athena.wi.rr.com 8.0-release-p4 freebsd 8.0-release-p4 #0: 
mon jul 12 20:22:27 utc 2010 root at i386-
builder.daemonology.net:usrobjusrsrcsysgeneric i386 '
    config_args='-sde -Dprefix=/usr/local -
Darchlib=/usr/local/lib/perl5/5.8.9/mach -Dprivlib=/usr/local/lib/perl5/5.8.9 
-Dman3dir=/usr/local/lib/perl5/5.8.9/perl/man/man3 -
Dman1dir=/usr/local/man/man1 -
Dsitearch=/usr/local/lib/perl5/site_perl/5.8.9/mach -
Dsitelib=/usr/local/lib/perl5/site_perl/5.8.9 -Dscriptdir=/usr/local/bin -
Dsiteman3dir=/usr/local/lib/perl5/5.8.9/man/man3 -
Dsiteman1dir=/usr/local/man/man1 -Ui_malloc -Ui_iconv -Uinstallusrbinperl -
Dcc=cc -Duseshrplib -Dinc_version_list=none -Dccflags=-
DAPPLLIB_EXP="/usr/local/lib/perl5/5.8.9/BSDPAN" -Doptimize=-O2 -pipe -fno-
strict-aliasing -Ud_dosuid -Ui_gdbm -Dusethreads=n -Dusemymalloc=y -
Duse64bitint'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef 
usemultiplicity=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=define use64bitall=undef uselongdouble=undef
    usemymalloc=y, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-DAPPLLIB_EXP="/usr/local/lib/perl5/5.8.9/BSDPAN" -
DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -
I/usr/local/include',
    optimize='-O2 -pipe -fno-strict-aliasing',
    cppflags='-DAPPLLIB_EXP="/usr/local/lib/perl5/5.8.9/BSDPAN" -
DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -
I/usr/local/include'
    ccversion='', gccversion='4.2.1 20070719  [FreeBSD]', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', 
lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -Wl,-E  -L/usr/local/lib'
    libpth=/usr/lib /usr/local/lib
    libs=-lgdbm -lm -lcrypt -lutil
    perllibs=-lm -lcrypt -lutil
    libc=, so=so, useshrplib=true, libperl=libperl.so
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='  -Wl,-
R/usr/local/lib/perl5/5.8.9/mach/CORE'
    cccdlflags='-DPIC -fPIC', lddlflags='-shared  -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: MYMALLOC PERL_MALLOC_WRAP USE_64_BIT_INT
                        USE_FAST_STDIO USE_LARGE_FILES USE_PERLIO
  Locally applied patches:
        defined-or
  Built under freebsd
  Compiled at Nov  5 2010 17:36:15
  @INC:
    /usr/local/lib/perl5/5.8.9/BSDPAN
    /usr/local/lib/perl5/site_perl/5.8.9/mach
    /usr/local/lib/perl5/site_perl/5.8.9
    /usr/local/lib/perl5/5.8.9/mach
    /usr/local/lib/perl5/5.8.9
In /etc/make.conf I have correct version (I didn't update perl).

I did check installed ports and is okay.
Thank you.
--------
http://jpgmag.com/people/lumiwa


More information about the freebsd-ports mailing list