ImageMagick, Djvu, and Perl-threaded - marked as IGNORE when updating

David Southwell david at vizion2000.net
Mon Dec 27 10:22:56 UTC 2010


> On 12/27/10 01:05, Roland Smith wrote:
> > On Sun, Dec 26, 2010 at 11:42:37PM +1000, Da Rock wrote:
> >>>>    Something I'm missing here? A fix would be nice, I should be used
> >>>>    to it though- ImageMagick _always_ has issues for me. I just
> >>>>    thought it'd be nice to get it updated for once- it looked so
> >>>>    close :)
> >>> 	
> >>> 	I'm getting something similar, have been for a couple of weeks:
> >>> ** Port marked as IGNORE: graphics/ImageMagick:
> >>> 	OpenEXR requires threads. . Perl is non-threaded. Reinstall Perl with
> >>> 	threads or undefine WITH_IMAGEMAGICK_PERL
> >>> 
> >>> ** Listing the failed packages (-:ignored / *:skipped / !:failed)
> >>> 
> >>> 	- graphics/ImageMagick (marked as IGNORE)
> >>> 	
> >>> 	(Follow-ups redirected to ports@, or I tried to.)
> >> 
> >> Hmm. I'm not alone then. I'll do some poking then and see what comes
> >> up... :)
> >> 
> >> Any hints guys?
> > 
> > Try building ImageMagick without perl support. Works for me, with EXR,
> > but haven't tested with Djvu;
> > 
> >      cd /usr/ports/graphics/ImageMagick
> >      make config
> >      
> >       ┌──────────────────────────────────────────────────────────────────
> >       ──┐ │                 Options for ImageMagick 6.6.5.10             
> >            │ │
> >       ┌────^(-)────────────────────────────────────────────────────────┐
> >       │
> >      
> >      ...
> >      
> >       │ │[X] IMAGEMAGICK_OPENEXR      OpenEXR support (needs threads)   
> >       │ │ │ │[X] IMAGEMAGICK_OPENMP       OpenMP for SMP (needs threads)
> >           │ │ │ │[ ] IMAGEMAGICK_PDF          PDF format support        
> >               │ │ │ │[ ] IMAGEMAGICK_PERL         Perl support          
> >                   │ │
> >      
> >      ...
> > 
> > Roland
> 
> ImageMagick is already installed, so getting something to work is not a
> problem. Its updating it...
> 
> What concerns me is perl-threaded _is_ installed but it can't see it.
Do you have in:
etc/make.conf
PERL_THREADED=true
??

David
Photographic Artist
Permanent Installations & Design
Creative Imagery and Advanced Digital Techniques
High Dynamic Range Photography & Official Portraiture
Combined darkroom & digital creations
& Systems Adminstrator for the vizion2000.net network


More information about the freebsd-ports mailing list