making all ports in /usr/ports on FreeBSD 8.1

Rob Farmer rfarmer at predatorlabs.net
Mon Dec 13 12:30:18 UTC 2010


On Sat, Dec 11, 2010 at 01:29, Norm Larkin <norml1231 at yahoo.com> wrote:
> Hello,
>
> I was idly trying to experiment and decided I wanted to see how long it took,
> how much disk space was involved, how hard it was on a system, and so on, to
> build the entire ports tree.  I loaded up a fresh system with FreeBSD 8.1R on
> i386, used all defaults for the installer options, had it install all sources
> and the ports tree, went into /usr/ports, set BATCH to yes, and did "make
> install".  It bombed within about an hour.  Figuring my ports were out of date,
> I repeated this after wiping all of /usr/local, /var/db/pkg, /usr/ports, and
> then using portsnap to fetch and install.  Same result.  I then tried loading
> the amd64 version.  Same thing.
>
> What am I doing dumb here (other than possibly trying to build all ports).  It
> seems to always get messed up on libxml2.
>
> Typescript follows, but I only did a script after it had already failed, so all
> the intermediate stuff is not there.
>
>
> Script started on Sat Dec 11 02:41:10 2010
> freebsd-81r-i386# cd /usr/ports
> freebsd-81r-i386# setenv BATCH yes
> freebsd-81r-i386# make install

There are a couple problems with this: first, some ports conflict, so
you can't have everything installed installed at once. You need to use
something like tinderbox to have the builds isolated from one another.
Secondly, as you've noticed, the first broken port causes the whole
thing to fail. Tinderbox would fix this too.

-- 
Rob Farmer


More information about the freebsd-ports mailing list