current ports Mk make fetch calls wget fails to support schemes

Julian H. Stacey jhs at
Tue Aug 31 17:40:03 UTC 2010

>Submitter-Id:	current-users
>Originator:	Julian H. Stacey
>Organization: BSD Linux Unix Consultancy, Munich/Muenchen.
>Confidential:	no 
>Synopsis:	current ports Mk make fetch calls wget fails to support schemes
>Severity:	serious 
>Priority:	high 
>Category:	ports
>Class:		sw-bug
>Release:	current
System: FreeBSD 8.0-RELEASE FreeBSD 8.0-RELEASE #0: Mon Jul 12 00:59:43 CEST 2010 jhs at amd64


Using a base of 8.0-RELEASE & 
cd /pri/FreeBSD/branches/-current/ports
setenv PORTSDIR `/bin/pwd`
cd sysutils/tarsnap
make fetch

Mk/ has regressed in current & now fails to fetch URLS of type 
with error:
	/usr/home/jhs/tmp/tarsnap-autoconf-1.0.27.tgz: Unsupported scheme.
	file:///host/gate/usr/home/jhs/tmp/tarsnap-autoconf-1.0.27.tgz: \
		 Unsupported scheme.

>From make.conf fragment:
	DIS_LOCAL+= /usr/home/jhs/tmp/distfiles/
	DIS_LOCAL+= file:///usr/home/jhs/tmp/distfiles/

make fetch used to call src/ BSD licensed fetch
it now calls FSF GNU licensed wget,
You can see why it fails with 
	cd sysutils/tarsnap ; make fetch-list

Even after one has found where 
	Unsupported scheme
comes from & tried to work round it with make.conf assertion of
as shown in
/usr/src/usr.bin/fetch is still not used.

	See above

	Revert Mk invocation back to longer invoke FSF/GNU licensed
	wget & instead again invoke BSD licensed src/ provided fetch,
	until such time as wget might be capable of offering all
	schemes BSD fetch already does.

More information about the freebsd-ports mailing list