lzmautils-devel move in UPDATING

Andriy Gapon avg at icyb.net.ua
Wed Sep 23 18:14:08 UTC 2009


on 23/09/2009 19:47 Olivier Smedts said the following:
> With a current ports tree (and installed ports a few days old),
> "pkg_version -vL =" said it couldn't compare version for
> lzmautils-devel, which is needed by KDE4.

You have hit a deficiency of portupgrade and its companion tools.

> I think there should be
> something about the lzmautils-devel move in UPDATING. I think the
> necessary commands are :
> 
> # portmaster -o archivers/xz archivers/lzmautils-devel

portmaster automatically detected the rename and did the right thing for me based
on MOVED. So, no hand-guiding is needed for it.

I am all for helping users, so I wouldn't object this particular request.
I know that I am generalizing, but are we going to put UPDATING entries for every
ports/packages tool that is not smart enough or has a bug? :-)

> or
> # portupgrade -o archivers/xz lzmautils-devel
> 
> Confirmed working with portupgrade. I don't use portmaster.
> # cat /var/db/pkg/xz-4.999.9/+REQUIRED_BY
> kdebase-runtime-4.3.1
> kdelibs-4.3.1_1
> kdeutils-4.3.1
> 
> Cheers
> 


-- 
Andriy Gapon


More information about the freebsd-ports mailing list