python26-2.6.2_3 fails patchset up on amd64

David Southwell david at vizion2000.net
Sat Sep 12 17:32:04 UTC 2009


> On Fri, Sep 11, 2009 at 09:00:27PM +0100, David Southwell wrote:
> > portupgrade -a failed. I then attempted the following which also failed
> > with identical error messages:
> 
> Hello David,
> 
> Patching  files/patch-setup.py :
> 
> % diff /PORTS/lang/python26/files/patch-setup.py /tmp
> 77c77
> < -        elif platform in ('freebsd4', 'freebsd5', 'freebsd6'):
> ---
> 
> > -        elif platform in ('freebsd4', 'freebsd5', 'freebsd6',
> > 'freebsd7', 'freebsd8'):
> 
> 81c81
> <              macros = dict(                  # FreeBSD 4-6
> ---
> 
> >              macros = dict(                  # FreeBSD
> 
> I build it sucessfully.
> 
> cheers,
> -at
> 
> > dns1# make
> > ===>  Found saved configuration for python26-2.6.2_3
> > ===>  Extracting for python26-2.6.2_3
> > => MD5 Checksum OK for python/Python-2.6.2.tgz.
> > => SHA256 Checksum OK for python/Python-2.6.2.tgz.
> > ===>  Patching for python26-2.6.2_3
> > /bin/cp -r /usr/ports/lang/python26/work/Python-2.6.2/Lib/plat-freebsd8
> > /usr/ports/lang/python26/work/Python-2.6.2/Lib/plat-freebsd9
> > /bin/mkdir -p /usr/ports/lang/python26/work/Python-2.6.2/portbld.static
> > /usr/ports/lang/python26/work/Python-2.6.2/portbld.shared/Modules
> > /bin/ln /usr/ports/lang/python26/work/Python-2.6.2/Lib/smtpd.py
> > /usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts/
> > /usr/bin/sed -e '1s,^.*$,#!/usr/local/bin/python2.6,'
> > /usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts/2to3  >
> > /usr/ports/lang/python26/work/`echo 2to3 | /usr/bin/sed -E -e
> > 's,smtpd,smtpd2.6,'  -e 's,2to3,2to3-2.6,'  -e
> > 's,(idle|pydoc|python-shared| python),\12.6,'`
> > /usr/bin/sed -e '1s,^.*$,#!/usr/local/bin/python2.6,'
> > /usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts/idle  >
> > /usr/ports/lang/python26/work/`echo idle | /usr/bin/sed -E -e
> > 's,smtpd,smtpd2.6,'  -e 's,2to3,2to3-2.6,'  -e
> > 's,(idle|pydoc|python-shared| python),\12.6,'`
> > /usr/bin/sed -e '1s,^.*$,#!/usr/local/bin/python2.6,'
> > /usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts/pydoc  >
> > /usr/ports/lang/python26/work/`echo pydoc | /usr/bin/sed -E -e
> > 's,smtpd,smtpd2.6,'  -e 's,2to3,2to3-2.6,'  -e
> > 's,(idle|pydoc|python-shared| python),\12.6,'`
> > /usr/bin/sed -e '1s,^.*$,#!/usr/local/bin/python2.6,'
> > /usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts/smtpd.py  >
> > /usr/ports/lang/python26/work/`echo smtpd.py | /usr/bin/sed -E -e
> > 's,smtpd,smtpd2.6,'  -e 's,2to3,2to3-2.6,'  -e
> > 's,(idle|pydoc|python-shared| python),\12.6,'`
> > /usr/bin/sed -i.bak -e  's,/usr/doc/python-
> > docs-,/usr/local/share/doc/python,g'
> > /usr/ports/lang/python26/work/Python-2.6.2/Lib/pydoc.py
> > /usr/bin/sed -i.bak -e  's|^\( *prefixes = .*\)\]$|\1, "/usr/local"]|g'
> > /usr/ports/lang/python26/work/Python-2.6.2/Lib/site.py
> > /usr/bin/sed -i.bak -e  's|^    \(..ASDLGEN.*\)$|       true|g'
> > /usr/ports/lang/python26/work/Python-2.6.2/Makefile.pre.in
> > /usr/bin/sed -i.bak -e  's|*\(..INSTALL_SCRIPT.*\)python-config$|#port
> > \1|' /usr/ports/lang/python26/work/Python-2.6.2/Makefile.pre.in
> > /usr/bin/sed -e 's|^#!.*|#!/usr/local/bin/python2.6|'
> > /usr/ports/lang/python26/work/Python-2.6.2/Misc/python-config.in >
> > /usr/ports/lang/python26/work/python2.6-config
> > /usr/bin/sed -e 's|^#!.*|#!/usr/local/bin/python-shared2.6|'
> > /usr/ports/lang/python26/work/Python-2.6.2/Misc/python-config.in >
> > /usr/ports/lang/python26/work/python-shared2.6-config
> > ===>  Applying extra patch
> > /usr/ports/lang/python26/files/extra-patch-setup.py ===>  Applying
> > FreeBSD patches for python26-2.6.2_3
> > 1 out of 11 hunks failed--saving rejects to setup.py.rej
> > => Patch patch-setup.py failed to apply cleanly.
> > => Patch(es) patch-Lib_test_test_threading.py
> > patch-Modules-_ctypes-libffi- configure patch-Python2.6-Lib_local.py
> > patch-Python_thread__pthread.h applied cleanly.
> > *** Error code 1
> >
> > Stop in /usr/ports/lang/python26.
> > *** Error code 1
> >
> > Stop in /usr/ports/lang/python26.
> > dns1#
> > Thanks in advance for any advice
> >
> > David
> 

Just cvsup ports and tried again here is what I am getting:

dns1# portupgrade -a                                                                                                 
--->  Upgrading 'py26-papyon-0.4.1' to 'py26-papyon-0.4.2' (net-im/papyon)                                           
--->  Building '/usr/ports/net-im/papyon'                                                                            
===>  Cleaning for py26-papyon-0.4.2                                                                                 
===>  Extracting for py26-papyon-0.4.2                                                                               
=> MD5 Checksum OK for papyon-0.4.2.tar.gz.                                                                          
=> SHA256 Checksum OK for papyon-0.4.2.tar.gz.                                                                       
===>  Patching for py26-papyon-0.4.2                                                                                 
===>  Applying FreeBSD patches for py26-papyon-0.4.2                                                                 
===>   py26-papyon-0.4.2 depends on file: /usr/local/lib/python2.6/site-
packages/gtk-2.0/gobject/_gobject.so - found 
===>   py26-papyon-0.4.2 depends on file: /usr/local/lib/python2.6/site-
packages/OpenSSL/SSL.so - found              
===>   py26-papyon-0.4.2 depends on file: /usr/local/lib/python2.6/site-
packages/Crypto/Hash/SHA.py - found          
===>   py26-papyon-0.4.2 depends on file: /usr/local/bin/python2.6 - not found                                       
===>    Verifying install for /usr/local/bin/python2.6 in 
/usr/ports/lang/python26                                   
===>  Found saved configuration for python26-2.6.2_3                                                                 
===>  Extracting for python26-2.6.2_3                                                                                
=> MD5 Checksum OK for python/Python-2.6.2.tgz.                                                                      
=> SHA256 Checksum OK for python/Python-2.6.2.tgz.                                                                   
===>  Patching for python26-2.6.2_3                                                                                  
/bin/cp -r /usr/ports/lang/python26/work/Python-2.6.2/Lib/plat-freebsd8  
/usr/ports/lang/python26/work/Python-2.6.2/Lib/plat-freebsd9
/bin/mkdir -p /usr/ports/lang/python26/work/Python-2.6.2/portbld.static 
/usr/ports/lang/python26/work/Python-2.6.2/portbld.shared/Modules
/bin/ln /usr/ports/lang/python26/work/Python-2.6.2/Lib/smtpd.py 
/usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts/                
/usr/bin/sed -e '1s,^.*$,#!/usr/local/bin/python2.6,'  
/usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts/2to3  > 
/usr/ports/lang/python26/work/`echo 2to3 | /usr/bin/sed -E -e 
's,smtpd,smtpd2.6,'  -e 's,2to3,2to3-2.6,'  -e 's,(idle|pydoc|python-shared|
python),\12.6,'`                                        
/usr/bin/sed -e '1s,^.*$,#!/usr/local/bin/python2.6,'  
/usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts/idle  > 
/usr/ports/lang/python26/work/`echo idle | /usr/bin/sed -E -e 
's,smtpd,smtpd2.6,'  -e 's,2to3,2to3-2.6,'  -e 's,(idle|pydoc|python-shared|
python),\12.6,'`                                        
/usr/bin/sed -e '1s,^.*$,#!/usr/local/bin/python2.6,'  
/usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts/pydoc  > 
/usr/ports/lang/python26/work/`echo pydoc | /usr/bin/sed -E -e 
's,smtpd,smtpd2.6,'  -e 's,2to3,2to3-2.6,'  -e 's,(idle|pydoc|python-shared|
python),\12.6,'`                                      
/usr/bin/sed -e '1s,^.*$,#!/usr/local/bin/python2.6,'  
/usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts/smtpd.py  > 
/usr/ports/lang/python26/work/`echo smtpd.py | /usr/bin/sed -E -e 
's,smtpd,smtpd2.6,'  -e 's,2to3,2to3-2.6,'  -e 's,(idle|pydoc|python-shared|
python),\12.6,'`                                
/usr/bin/sed -i.bak -e  's,/usr/doc/python-
docs-,/usr/local/share/doc/python,g'  
/usr/ports/lang/python26/work/Python-2.6.2/Lib/pydoc.py                     
/usr/bin/sed -i.bak -e  's|^\( *prefixes = .*\)\]$|\1, "/usr/local"]|g'  
/usr/ports/lang/python26/work/Python-2.6.2/Lib/site.py                              
/usr/bin/sed -i.bak -e  's|^    \(..ASDLGEN.*\)$|       true|g'  
/usr/ports/lang/python26/work/Python-2.6.2/Makefile.pre.in                                  
/usr/bin/sed -i.bak -e  's|*\(..INSTALL_SCRIPT.*\)python-config$|#port \1|'  
/usr/ports/lang/python26/work/Python-2.6.2/Makefile.pre.in                      
/usr/bin/sed -e 's|^#!.*|#!/usr/local/bin/python2.6|'  
/usr/ports/lang/python26/work/Python-2.6.2/Misc/python-config.in > 
/usr/ports/lang/python26/work/python2.6-config                                                                                                                                                  
/usr/bin/sed -e 's|^#!.*|#!/usr/local/bin/python-shared2.6|'  
/usr/ports/lang/python26/work/Python-2.6.2/Misc/python-config.in > 
/usr/ports/lang/python26/work/python-shared2.6-config                                                                                                                                    
===>  Applying extra patch /usr/ports/lang/python26/files/extra-patch-setup.py                                                                               
===>  Applying FreeBSD patches for python26-2.6.2_3                                                                                                          
1 out of 11 hunks failed--saving rejects to setup.py.rej                                                                                                     
=> Patch patch-setup.py failed to apply cleanly.                                                                                                             
=> Patch(es) patch-Lib_test_test_threading.py patch-Modules-_ctypes-libffi-
configure patch-Python2.6-Lib_local.py patch-Python_thread__pthread.h applied 
cleanly.                                                                                                                                                         
*** Error code 1                                                                                                                                             

Stop in /usr/ports/lang/python26.
*** Error code 1                 

Stop in /usr/ports/lang/python26.
*** Error code 1                 

Stop in /usr/ports/net-im/papyon.
--->  Backing up the old version 
--->  Uninstalling the old version
--->  Deinstalling 'py26-papyon-0.4.1'
pkg_delete: package 'py26-papyon-0.4.1' is required by these other packages
and may not be deinstalled (but I'll delete it anyway):                    
py26-telepathy-butterfly-0.5.0                                             
pkg_delete: '/usr/local/lib/python2.6/site-
packages/papyon/gnet/proxy/HTTPConnect.pyc' fails original MD5 checksum - 
deleted anyway.
pkg_delete: '/usr/local/lib/python2.6/site-
packages/papyon/gnet/proxy/proxy_infos.pyc' fails original MD5 checksum - 
deleted anyway.
pkg_delete: '/usr/local/lib/python2.6/site-packages/papyon/msnp/command.pyc' 
fails original MD5 checksum - deleted anyway.          
pkg_delete: '/usr/local/lib/python2.6/site-packages/papyon/msnp/constants.pyc' 
fails original MD5 checksum - deleted anyway.        
pkg_delete: '/usr/local/lib/python2.6/site-packages/papyon/msnp/mailbox.pyc' 
fails original MD5 checksum - deleted anyway.          
pkg_delete: '/usr/local/lib/python2.6/site-
packages/papyon/msnp/notification.pyc' fails original MD5 checksum - deleted 
anyway.     
pkg_delete: '/usr/local/lib/python2.6/site-
packages/papyon/msnp/switchboard.pyc' fails original MD5 checksum - deleted 
anyway.      
pkg_delete: '/usr/local/lib/python2.6/site-packages/papyon/profile.pyc' fails 
original MD5 checksum - deleted anyway.               
pkg_delete: '/usr/local/lib/python2.6/site-
packages/papyon/service/AddressBook/scenario/contacts/accept_invite.pyc' fails 
original MD5 checksum - deleted anyway.                                                                                                                                                         
pkg_delete: '/usr/local/lib/python2.6/site-
packages/papyon/service/AddressBook/scenario/contacts/messenger_contact_add.pyc' 
fails original MD5 checksum - deleted anyway.                                                                                                                                                 
pkg_delete: '/usr/local/lib/python2.6/site-
packages/papyon/service/description/SingleSignOn/RequestMultipleSecurityTokens.pyc' 
fails original MD5 checksum - deleted anyway.                                                                                                                                              
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 1081 packages 
found (-1 +0) (...) done]                                                          
--->  Installing the new version via the port                                                                                                                
===>   py26-papyon-0.4.2 depends on file: /usr/local/lib/python2.6/site-
packages/gtk-2.0/gobject/_gobject.so - found                                         
===>   py26-papyon-0.4.2 depends on file: /usr/local/lib/python2.6/site-
packages/OpenSSL/SSL.so - found                                                      
===>   py26-papyon-0.4.2 depends on file: /usr/local/lib/python2.6/site-
packages/Crypto/Hash/SHA.py - found                                                  
===>   py26-papyon-0.4.2 depends on file: /usr/local/bin/python2.6 - not found                                                                               
===>    Verifying reinstall for /usr/local/bin/python2.6 in 
/usr/ports/lang/python26                                                                         
===>  Patching for python26-2.6.2_3                                                                                                                          
/bin/cp -r /usr/ports/lang/python26/work/Python-2.6.2/Lib/plat-freebsd8  
/usr/ports/lang/python26/work/Python-2.6.2/Lib/plat-freebsd9                        
/bin/mkdir -p /usr/ports/lang/python26/work/Python-2.6.2/portbld.static 
/usr/ports/lang/python26/work/Python-2.6.2/portbld.shared/Modules                    
/bin/ln /usr/ports/lang/python26/work/Python-2.6.2/Lib/smtpd.py 
/usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts/                                    
ln: /usr/ports/lang/python26/work/Python-2.6.2/Tools/scripts//smtpd.py: File 
exists                                                                          
*** Error code 1                                                                                                                                             

Stop in /usr/ports/lang/python26.
*** Error code 1                 

Stop in /usr/ports/lang/python26.
*** Error code 1                 

Stop in /usr/ports/lang/python26.
*** Error code 1                 

Stop in /usr/ports/net-im/papyon.
*** Error code 1                 

Stop in /usr/ports/net-im/papyon.
===>  Cleaning for python26-2.6.2_3
===>  Cleaning for py26-papyon-0.4.2
--->  Cleaning out obsolete shared libraries
--->  Upgrading 'xcb-util-0.3.5' to 'xcb-util-0.3.6' (x11/xcb-util)


More information about the freebsd-ports mailing list