Script "configure" failed unexpectedly

Stephan Sann stephan at sann.name
Thu Sep 3 17:35:14 UTC 2009


Hello,

while trying:
/usr/ports/graphics/xsane -> make -DFORCE_PKG_REGISTER install clean

I got:

updating cache ./config.cache
ltconfig: `/usr/local/share/libtool/config/ltmain.sh' does not exist
Try `ltconfig --help' for more information.
configure: error: libtool configure failed
===>  Script "configure" failed unexpectedly.
Please report the problem to ports at FreeBSD.org [maintainer] and attach the
"/usr/ports/graphics/aalib/work/aalib-1.4.0/config.log" including the output
of the failure of your make command. Also, it might be a good idea to 
provide
an overview of all packages installed on your system (e.g. an `ls
/var/db/pkg`).


Attached you find the asked File.

# uname -a
FreeBSD lotk1 7.2-STABLE FreeBSD 7.2-STABLE #6: Wed Jun 24 18:53:33 EDT 
2009 
root at build7x64.pcbsd.org:/usr/obj/pcbsd-build72/cvs/7.2-src/sys/PCBSD  amd64


Thanks in advance for any help!

Best regards
Stephan


# ls /var/db/pkg
ORBit2-2.14.17                  gamin-0.1.10_2 
libXrandr-1.3.0                 p5-Digest-SHA1-2.12
OpenEXR-1.6.1_1                 gcc-4.3.4_20090517 
libXrender-0.9.4_1              p5-XML-Parser-2.36_1
acroreadwrapper-0.0.20090328    gconf2-2.26.1_1 
libXt-1.0.5_1                   p5-gettext-1.05_2
arts-1.5.10_1,1                 gdbm-1.8.3_3 
libXtst-1.0.3_1                 pango-1.24.2
asciidoc-8.4.5_1                getopt-1.1.4_1 
libXxf86vm-1.0.2                pciids-20090224
aspell-0.60.6_2                 gettext-0.17_1 
liba52-0.7.4_2                  pcre-7.9
atk-1.26.0                      ghostscript8-8.64_2 
libart_lgpl-2.3.20,1            perl-5.8.9_2
autoconf-2.62                   gio-fam-backend-2.20.1 
libaudiofile-0.2.6              pixman-0.15.2
autoconf-wrapper-20071109       glib-2.20.1 
libbonobo-2.24.1                pkg-config-0.23_1
automake-1.10.1                 gmake-3.81_3 
libbonoboui-2.24.1              pkgdb.db
automake-1.9.6_3                gnome-doc-utils-0.16.1 
libcddb-1.3.0                   png-1.2.35
automake-wrapper-20071109       gnome-icon-theme-2.26.0_1 
libcdio-0.78.2_2                policykit-0.9_4
avahi-app-0.6.25_1              gnome-keyring-2.26.1_1 
libcheck-0.9.6                  policykit-gnome-0.9.2
bash-4.0.17                     gnome-mime-data-2.18.0_3 
libdaemon-0.12                  poppler-0.10.6
bigreqsproto-1.0.2              gnome-mount-0.8_2 
libdnet-1.11_3                  poppler-data-0.2.1
bitstream-vera-1.10_4           gnome-vfs-2.24.1 
libdrm-2.4.9                    poppler-qt-0.10.6
cairo-1.8.6_1,1                 gnome_subr-1.0 
libexif-0.6.17                  popt-1.7_5
cdparanoia-3.9.8_8              gnomehier-2.3_12 
libfontenc-1.0.4                portaudio-18.1_2
celt-0.5.2                      gnutls-2.6.5 
libgcrypt-1.4.4                 portmanager-0.4.1_9
compositeproto-0.4              gsfonts-8.11_4 
libglade2-2.6.4                 printproto-1.0.4
consolekit-0.3.0_8              gtk-2.16.1 
libglut-7.4.2_1                 py25-libxml2-2.7.3
cups-base-1.3.10_2              gvfs-1.2.2 
libgmp-4.3.1                    python25-2.5.4_1
cups-client-1.3.10_2            hal-0.5.11_23 
libgnome-2.26.0                 qt-3.3.8_9
cups-image-1.3.10_2             help2man-1.36.4_3 
libgnomecanvas-2.26.0           qt4-corelib-4.4.3
damageproto-1.1.0_2             hicolor-icon-theme-0.10_2 
libgnomeui-2.24.1               qt4-moc-4.4.3
dbus-1.2.4.6                    iceauth-1.0.2 
libgpg-error-1.7                qt4-qmake-4.4.3
dbus-glib-0.80                  ilmbase-1.0.1_1 
libgphoto2-2.4.5                qt4-rcc-4.4.3
desktop-file-utils-0.15_1       inputproto-1.5.0 
libiconv-1.11_1                 qt4-uic-4.4.3
dev86-0.16.17                   intltool-0.40.6 
libidn-1.13                     randrproto-1.3.0
djbfft-0.76_2                   iso-codes-3.10.1 
libltdl-1.5.26                  rarian-0.8.1
dmidecode-2.10                  iso8879-1986_2 
libmad-0.15.1b_2                recordproto-1.13.2
docbook-1.4                     jackit-0.116.2_2 
libmng-1.0.10                   renderproto-0.9.3
docbook-4.1_3                   jasper-1.900.1_7 
libnotify-0.4.5                 rkhunter-1.3.4
docbook-4.2                     javavmwrapper-2.3.2 
libogg-1.1.3,4                  ruby-1.8.7.160_4,1
docbook-4.3                     jpeg-6b_7 
libpaper-1.1.21_3               samba-libsmbclient-3.0.34_1
docbook-4.4_2                   jpeg-7 
libproxy-0.2.3                  sane-backends-1.0.20_3
docbook-4.5_2                   kBuild-0.1.5.p1_1 
libpthread-stubs-0.1            shared-mime-info-0.60_1
docbook-5.0_1                   kbproto-1.0.3 
libsamplerate-0.1.7_1           sqlite3-3.6.13
docbook-sk-4.1.2_4              kdegraphics-3.5.10_2 
libsigsegv-2.5                  startup-notification-0.10
docbook-xml-4.2_1               kdehier-1.0_11 
libsndfile-1.0.19               t1lib-5.1.2_1,1
docbook-xml-4.3                 kdelibs-3.5.10 
libsoup-2.26.1                  tiff-3.8.2_3
docbook-xml-4.4_1               lcms-1.18,1 
libtasn1-2.1                    unzip-5.52_5
docbook-xml-4.5                 libGL-7.4.1_1 
libthai-0.1.5_3                 upnp-1.6.5,1
docbook-xsl-1.74.0_1            libGLU-7.4.1_1 
libtool-1.5.26                  ushare-1.1a
dri2proto-2.0                   libICE-1.0.4_1,1 
libusb-0.1.12_4                 v4l_compat-1.0.20060801
eclipse-3.4.1                   libIDL-0.8.13 
libvolume_id-0.81.1             wget-1.11.4
encodings-1.0.2,1               libSM-1.1.0_1,1 
libvorbis-1.2.0_3,3             xbitmaps-1.0.1
esound-0.2.41                   libX11-1.2.1,1 
libxcb-1.2_1                    xcb-proto-1.4
expat-2.0.1                     libXau-1.0.4 
libxml2-2.7.3                   xcb-util-0.3.4
fftw3-3.2                       libXaw-1.0.5_1,1 
libxslt-1.1.24_2                xcmiscproto-1.1.2
firefox-2.0.0.20_7,1            libXcomposite-0.4.0,1 
lsof-4.82,4                     xextproto-7.0.5
fixesproto-4.0                  libXcursor-1.1.9_1 
lua-5.1.4                       xf86bigfontproto-1.1.2
flac-1.2.1                      libXdamage-1.1.1 
m4-1.4.13,1                     xf86vidmodeproto-2.2.2
font-bh-ttf-1.0.0               libXdmcp-1.0.2_1 
mDNSResponder-108               xineramaproto-1.1.2
font-misc-ethiopic-1.0.0        libXext-1.0.5,1 
mkfontdir-1.0.4                 xmlcatmgr-2.2
font-misc-meltho-1.0.0_1        libXfixes-4.0.3_1 
mkfontscale-1.0.6               xmlcharent-0.3_2
font-util-1.0.1                 libXft-2.1.13 
mpfr-2.4.1_1                    xorg-fonts-truetype-7.4
fontconfig-2.6.0,1              libXi-1.2.1,1 
nas-1.9.1_3                     xorg-macros-1.2.1
freetype2-2.3.9_1               libXinerama-1.0.3,1 
nmap-4.85.b7_1                  xpdf-3.02_11
fribidi-0.10.9                  libXmu-1.0.4,1                  nspr-4.7 
                        xproto-7.0.15
fusefs-kmod-0.3.9.p1.20080208_5 libXp-1.0.0,1 
nss-3.11.9_2                    xtrans-1.2.3
fusefs-libs-2.7.4               libXpm-3.5.7 
open-motif-2.2.3_6              zip-3.0
-------------- next part --------------
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:584: checking for a BSD compatible install
configure:637: checking whether build environment is sane
configure:694: checking whether make sets ${MAKE}
configure:740: checking for working aclocal
configure:753: checking for working autoconf
configure:766: checking for working automake
configure:779: checking for working autoheader
configure:792: checking for working makeinfo
configure:812: checking host system type
configure:833: checking target system type
configure:882: checking for gcc
configure:995: checking whether the C compiler (cc -O2 -fno-strict-aliasing -pipe ) works
configure:1011: cc -o conftest -O2 -fno-strict-aliasing -pipe   conftest.c  1>&5
configure:1037: checking whether the C compiler (cc -O2 -fno-strict-aliasing -pipe ) is a cross-compiler
configure:1042: checking whether we are using GNU C
configure:1051: cc -E conftest.c
configure:1070: checking whether cc accepts -g
configure:1171: checking build system type
configure:1191: checking for ranlib
configure:1230: checking for ld used by GCC
configure:1292: checking if the linker (/usr/bin/ld) is GNU ld
GNU ld version 2.15 [FreeBSD] 2004-05-23
configure:1308: checking for BSD-compatible nm
configure:1344: checking whether ln -s works


More information about the freebsd-ports mailing list