FreeBSD Port: mc-4.6.2 lynx-like motion forgot

Daniel Dvořák dandee at hellteam.net
Tue Sep 1 09:33:16 UTC 2009


Hi all,
 
at the beginning I apologize for cross-mailling becuase I really don´t know which mailling list or mail address is the best one for sending my problem.
 
I needed to set up lynx-like motion in configuration of mc. I did it and saved configuration. The application told me that it saved my configuration to ~/.mc/ini.
 
Before I ended mc I tested new setted lynx-like motion and it worked. Next day I started mc again and lynx-like motion did not work at all.
 
I checked my configuration menu and lynx-like motion was not enabled. Why ? I wanted to check it directly in ini file, but I didn´t found any .mc directory and of course any ini file.
 
I tested this on another system where .mc directory and ini file were there. And it worked with lynx-like motion enabled well. I ended mc twice and it always worked again and again.
 
So as I guess my problem is not actually lynx-like motion, but not being ini file. I checked ownership of my home directory and privileges and it were standard.
 
The problem is the same for user and super-user account. I tested sh and bash command interpreter. No diffrence.
 
Some important information about servers:
 
[XYZ$ uname -a
FreeBSD XYZ 7.2-STABLE-200906 FreeBSD 7.2-STABLE-200906 #0: Sun Jun  7 10:23:49 UTC 2009     root at driscoll.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC  amd64
 
or second server
 
[ABC]$ uname -a
FreeBSD ABC 7.2-RELEASE-p3 FreeBSD 7.2-RELEASE-p3 #0: Wed Jun 24 00:57:44 UTC 2009     root at i386-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  i386
 
mc-4.6.2            Midnight Commander, a free Norton Commander Clone
 
# This file is auto-generated by 'make config'.
# No user-servicable parts inside!
# Options for mc-4.6.2
_OPTIONS_READ=mc-4.6.2
WITH_UTF8=true
WITH_SLANG=true
WITH_ICONV=true
WITH_NLS=true
WITH_EDIT=true
WITHOUT_X11=true
WITH_SUBSHELL=true
WITH_SAMBA=true

So what is wrong and where ?
 
Daniel


More information about the freebsd-ports mailing list