proftpd problems (ldap, quota, tds) and a patch

Wesley Shields wxs at
Wed Oct 14 13:39:21 UTC 2009

On Wed, Oct 14, 2009 at 09:42:49AM +0200, Peter Czanik wrote:
> Hello,
> I ran into a couple of problems with the proftpd port after the latest
> update.
> Until now I compiled LDAP without the additional quota support. Now,
> even if I select only "LDAP" in the config menu, I get:
> ==> Configuring with mod_ldap:mod_tls:mod_quotatab_ldap                   
> And compilation fails with ugly errors, unless I also select "quota" in
> the config menu.
> The other problem is, that TDS is installed, even if it is not selected
> in the config menu.
> The following fix is tested and works for me, even if not I'm not really
> sure, if it is really correct. All the problematic config options seem
> to work again as expected.

I have a similar patch I worked up last night that I'm sending to the
maintainer for review today. Expect a fix once he has reviewed it.

-- WXS

More information about the freebsd-ports mailing list