does istgt works on -CURRENT ?

Daniel Ernst ernst at
Fri Nov 27 11:43:04 UTC 2009

Hi Sergey,

It seems that it doesn´t effect FreeBSD 9.0 only. I tried it on FreeBSD 8.0. And I get the same error. I have FreeBSD 8.0 x64 Release installed and than created a zpool, not updated, and had with zfs created a target. After that I installed istgt with the ports. Made the same configuration as u, besides the IP-Address ;), and got this failure by starting istgt:

Starting istgt.
Istgt version 0.2 (20090428)
Istgt_lu.c:1213:istgt_lu_add_unit: ***ERROR*** LU1: LUN0: format error
Istgt_lu.c:1473:istgt_lu_init: ***ERROR*** lu_add_unit() failed
Istgt.c:1247:main: ***ERROR*** istgt_lu_init() failed
/usr/local/etc/rc.d/istgt: WARNING: failed to start istgt

Have someone an idea?

Greetings Daniel

Hi Daisuke Aoyama and list 

I'm trying run iSCSI target on my -CURRENT box 
%uname -a
FreeBSD current.domain 9.0-CURRENT FreeBSD 9.0-CURRENT #6
r198480: Tue Nov  3 10:03:09 EET 2009
root at current.domain:/usr/obj/usr/src/sys/KERN  amd64

%pkg_info -xI istgt
istgt-20090428      An iSCSI target for FreeBSD 7.x with ZFS

%zfs upgrade
This system is currently running ZFS filesystem version 3.

All filesystems are formatted with the current version.
%zpool  upgrade
This system is currently running ZFS pool version 13.

All pools are formatted using this version.

Now my actions Step-by-step:

# zfs create tank/share/target
# zfs set mountpoint=none tank/share/target
# zfs set quota=20G tank/share/target
# cd /usr/local/etc/istgt
# cp auth.conf.sample auth.conf
# cp istgt.conf.sample istgt.conf
# cp istgtcontrol.conf.sample istgtcontrol.conf

my server`s IP is
I made some changes on istgt.conf:
1) section [PortalGroup1]:
"Portal DA1" -> "Portal DA1" 
2) sections [LogicalUnit1]:
"LUN0 Storage /tank/iscsi/istgt-disk1 10G" -> "LUN0
Storage /tank/share/target"

Now I'm trying start istgt:
# /usr/local/etc/rc.d/istgt onestart
istgt version 0.2 (20090428)
istgt_lu.c:1213:istgt_lu_add_unit: ***ERROR*** LU1: LUN0: format error
istgt_lu.c:1473:istgt_lu_init: ***ERROR*** lu_add_unit() failed
istgt.c:1247:main: ***ERROR*** istgt_lu_init() failed
/usr/local/etc/rc.d/istgt: WARNING: failed to start istgt

where I'm wrong?

More information about the freebsd-ports mailing list