FreeBSD Port: gtkam-

Sven Göttner post at
Mon Nov 16 20:50:23 UTC 2009

	Dear maintainer of gtkam,

just tried out gktam on FBSD 7.1-RELEASE-p8 and was closed to giving
up, since my camera (Panasonic DMC-FZ50) was listed on as
supported device and gtkam recognized it (almost correctly as FZ20 -
but OK...) - but connection via PTP just resulted in an "PTP I/O-Error".
Debugging with --debug and --debug-logfile also just listed an "unknown
error". I could not connect to the camera or even view/download files.

Finally I installed gphoto2 from the ports, since I hoped to get more
help or information from a command line tool (proved to be a good
strategy while trying to get my handheld to work under FBSD) and
then (accidently) started gphoto2 as root - and it flawlessly connected
to the camera and downloaded the pictures.

Since mounting the camera as da* device (usb mass storage) worked
perfectly (which would have been my fallback solution, anyway), I could
not explain this behaviour to me.

It took me quite a while to guess that obviously when connecting via
PTP, an ugen* device is used and not the usual da* device for USB


add path 'ugen*' 0660 group operator

to /etc/devfs.rules (as done before for USB sticks) and restarting
devfs and devd via the /etc/rc.d/dev* scripts finally solved the
problem and now also non-root users are able to connect to the camera
via PTP.

So I suggest adding a post-install notice in the install routine for
FBSD that makes the user aware of this step. I have not found this
requirement documented elsewhere...

    Greetz and thanks for maintaining gtkam,


More information about the freebsd-ports mailing list