Configuring 'RUN_DEPENDS'

Wesley Shields wxs at FreeBSD.org
Tue Mar 3 19:05:32 PST 2009


On Tue, Mar 03, 2009 at 05:38:14PM -0500, Jerry wrote:
> On Tue, 3 Mar 2009 20:47:15 +0300
> Dmitry Marakasov <amdmi3 at amdmi3.ru> wrote:
> 
> >As far as I understand, that won't work with clamav-devel.
> >RUN_DEPENDS=	clamav>=0.94.2:${PORTSDIR}/security/clamav
> >makes a port depend not on installed file but on specific package,
> >so clamav-devel will likely not match this rule. I think there's
> >no need in such strict dependency, as clamav 0.94.2 is in the tree
> >for 3 months already.
> 
> I have given up on the idea too. There is probably a way; however, it
> is beyond my meager skills. I am just using:
> 
> 	clamav>=0.94.2:${PORTSDIR}/security/clamav
> 
> It will probably cause a conflict with some users who have the 'devel'
> version installed though. In any case, version 95 should be release
> shortly. It is all ready at 95RC1 or 2.

If either clamav or clamav-devel will work you can just specify a
dependency on sbin/clamd?

-- WXS


More information about the freebsd-ports mailing list